mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
88 lines
3.3 KiB
Diff
88 lines
3.3 KiB
Diff
diff -urN xf86-input-evtouch-0.8.8.orig/ev_calibrate.c xf86-input-evtouch-0.8.8.debian/ev_calibrate.c
|
|
--- xf86-input-evtouch-0.8.8.orig/ev_calibrate.c 2009-04-27 03:59:41.337760156 +0200
|
|
+++ xf86-input-evtouch-0.8.8.debian/ev_calibrate.c 2009-04-27 04:01:33.221079795 +0200
|
|
@@ -218,7 +218,7 @@
|
|
int cap_style = CapButt; /* style of the line's edje and */
|
|
int join_style = JoinBevel; /* joined lines. */
|
|
|
|
- int event_mask = ExposureMask | ButtonReleaseMask | PointerMotionMask | KeyPressMask;
|
|
+ int event_mask = ExposureMask | ButtonPressMask | ButtonReleaseMask | PointerMotionMask | KeyPressMask;
|
|
|
|
int depth;
|
|
int screen_num;
|
|
diff -urN xf86-input-evtouch-0.8.8.orig/evtouch.c xf86-input-evtouch-0.8.8.debian/evtouch.c
|
|
--- xf86-input-evtouch-0.8.8.orig/evtouch.c 2009-04-27 03:59:41.341094317 +0200
|
|
+++ xf86-input-evtouch-0.8.8.debian/evtouch.c 2009-04-27 04:01:33.217744675 +0200
|
|
@@ -30,8 +30,8 @@
|
|
|
|
#define _evdev_touch_C_
|
|
|
|
-#include <xf86Version.h>
|
|
-#if XF86_VERSION_CURRENT >= XF86_VERSION_NUMERIC(3,9,0,0,0)
|
|
+#include <xorgVersion.h>
|
|
+#if XORG_VERSION_CURRENT >= XORG_VERSION_NUMERIC(3,9,0,0,0)
|
|
#define XFREE86_V4
|
|
#endif
|
|
|
|
@@ -74,7 +74,6 @@
|
|
#include "xf86_OSproc.h"
|
|
#include "xf86Xinput.h"
|
|
#include "exevents.h"
|
|
-#include "xf86OSmouse.h"
|
|
#include "randrstr.h"
|
|
|
|
#ifndef NEED_XF86_TYPES
|
|
@@ -139,7 +138,7 @@
|
|
"Kenan Esau",
|
|
MODINFOSTRING1,
|
|
MODINFOSTRING2,
|
|
- XF86_VERSION_CURRENT,
|
|
+ XORG_VERSION_CURRENT,
|
|
0, 8, 8,
|
|
ABI_CLASS_XINPUT,
|
|
ABI_XINPUT_VERSION,
|
|
@@ -306,7 +305,7 @@
|
|
}
|
|
|
|
if (pos_changed == 1) {
|
|
-#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) == 2
|
|
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 2
|
|
ConvertProc(priv->local, 0, 2,
|
|
priv->raw_x, priv->raw_y,
|
|
0, 0, 0, 0,
|
|
@@ -370,7 +369,7 @@
|
|
priv->raw_y = priv->min_y;
|
|
}
|
|
|
|
-#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) == 2
|
|
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 2
|
|
ConvertProc(priv->local, 0, 2,
|
|
priv->raw_x, priv->raw_y,
|
|
0, 0, 0, 0,
|
|
@@ -653,14 +652,13 @@
|
|
* Device reports motions on 2 axes in absolute coordinates.
|
|
* Axes min and max values are reported in raw coordinates.
|
|
*/
|
|
- if (InitValuatorClassDeviceStruct(dev, 2, xf86GetMotionEvents,
|
|
+ if (InitValuatorClassDeviceStruct(dev, 2,
|
|
local->history_size, Absolute) == FALSE)
|
|
{
|
|
ErrorF ("Unable to allocate EVTouch touchscreen ValuatorClassDeviceStruct\n");
|
|
return !Success;
|
|
}
|
|
|
|
-#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) == 2
|
|
xf86InitValuatorAxisStruct(dev, 0, 0, priv->screen_width,
|
|
1024,
|
|
EV_AXIS_MIN_RES /* min_res */ ,
|
|
@@ -671,10 +669,6 @@
|
|
EV_AXIS_MIN_RES /* min_res */ ,
|
|
EV_AXIS_MAX_RES /* max_res */ );
|
|
xf86InitValuatorDefaults(dev, 1);
|
|
-#else
|
|
- xf86InitValuatorAxisStruct(dev, 0, priv->min_x, priv->max_x,
|
|
- xf86InitValuatorDefaults(dev, 1);
|
|
-#endif
|
|
|
|
/* Initial position of pointer on screen: Centered */
|
|
priv->cur_x=(priv->max_x - priv->min_x)/2;
|