mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-12-08 23:03:46 +00:00
149 lines
6.2 KiB
Diff
149 lines
6.2 KiB
Diff
diff -ruN -x .gitignore -x .cvsignore xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/Makefile.am xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/Makefile.am
|
|
--- xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/Makefile.am 2008-10-21 05:03:43.000000000 +0000
|
|
+++ xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/Makefile.am 2009-02-02 21:06:55.000000000 +0000
|
|
@@ -28,8 +28,7 @@
|
|
.PHONY: ChangeLog
|
|
|
|
ChangeLog:
|
|
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || \
|
|
- (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
|
|
+ $(CHANGELOG_CMD)
|
|
|
|
dist-hook: ChangeLog
|
|
|
|
diff -ruN -x .gitignore -x .cvsignore xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/README xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/README
|
|
--- xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/README 1970-01-01 00:00:00.000000000 +0000
|
|
+++ xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/README 2009-02-02 21:06:55.000000000 +0000
|
|
@@ -0,0 +1,20 @@
|
|
+xf86-input-elographics - Elographics input driver for the Xorg X server
|
|
+
|
|
+Please submit bugs & patches to the Xorg bugzilla:
|
|
+
|
|
+ https://bugs.freedesktop.org/enter_bug.cgi?product=xorg
|
|
+
|
|
+All questions regarding this software should be directed at the
|
|
+Xorg mailing list:
|
|
+
|
|
+ http://lists.freedesktop.org/mailman/listinfo/xorg
|
|
+
|
|
+The master development code repository can be found at:
|
|
+
|
|
+ git://anongit.freedesktop.org/git/xorg/driver/xf86-input-elographics
|
|
+
|
|
+ http://cgit.freedesktop.org/xorg/driver/xf86-input-elographics
|
|
+
|
|
+For more information on the git code manager, see:
|
|
+
|
|
+ http://wiki.x.org/wiki/GitPage
|
|
diff -ruN -x .gitignore -x .cvsignore xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/configure.ac xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/configure.ac
|
|
--- xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/configure.ac 2008-10-21 05:03:43.000000000 +0000
|
|
+++ xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/configure.ac 2009-02-02 21:06:55.000000000 +0000
|
|
@@ -32,15 +32,16 @@
|
|
|
|
AM_MAINTAINER_MODE
|
|
|
|
-DRIVER_NAME=elographics
|
|
-AC_SUBST([DRIVER_NAME])
|
|
-
|
|
+# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
|
|
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
|
|
+XORG_MACROS_VERSION(1.2)
|
|
AM_CONFIG_HEADER([config.h])
|
|
|
|
# Checks for programs.
|
|
AC_DISABLE_STATIC
|
|
AC_PROG_LIBTOOL
|
|
AC_PROG_CC
|
|
+XORG_CWARNFLAGS
|
|
|
|
AH_TOP([#include "xorg-server.h"])
|
|
|
|
@@ -77,16 +78,18 @@
|
|
# Checks for pkg-config packages
|
|
PKG_CHECK_MODULES(XORG, xorg-server xproto $REQUIRED_MODULES)
|
|
sdkdir=$(pkg-config --variable=sdkdir xorg-server)
|
|
-
|
|
-CFLAGS="$CFLAGS $XORG_CFLAGS "' -I$(top_srcdir)/src'
|
|
-AC_SUBST([CFLAGS])
|
|
+XORG_CFLAGS="$CWARNFLAGS $XORG_CFLAGS"
|
|
|
|
# Checks for libraries.
|
|
|
|
# Checks for header files.
|
|
AC_HEADER_STDC
|
|
|
|
+DRIVER_NAME=elographics
|
|
+AC_SUBST([DRIVER_NAME])
|
|
+
|
|
XORG_MANPAGE_SECTIONS
|
|
XORG_RELEASE_VERSION
|
|
+XORG_CHANGELOG
|
|
|
|
AC_OUTPUT([Makefile src/Makefile man/Makefile])
|
|
diff -ruN -x .gitignore -x .cvsignore xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/man/elographics.man xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/man/elographics.man
|
|
--- xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/man/elographics.man 2008-10-21 05:03:43.000000000 +0000
|
|
+++ xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/man/elographics.man 2009-02-02 21:06:55.000000000 +0000
|
|
@@ -75,7 +75,7 @@
|
|
.BI "Option \*qModel\*q \*q" string \*q
|
|
The touchscreen model. Default: unset. Supported models: "Sunit dSeries".
|
|
.SH "SEE ALSO"
|
|
-__xservername__(__appmansuffix__), __xconfigfile__(__filemansuffix__), xorgconfig(__appmansuffix__), Xserver(__appmansuffix__), X(__miscmansuffix__).
|
|
+__xservername__(__appmansuffix__), __xconfigfile__(__filemansuffix__), Xserver(__appmansuffix__), X(__miscmansuffix__).
|
|
.SH AUTHORS
|
|
Authors include:
|
|
Patrick Lecoanet
|
|
diff -ruN -x .gitignore -x .cvsignore xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/src/Makefile.am xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/src/Makefile.am
|
|
--- xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/src/Makefile.am 2008-10-21 05:03:43.000000000 +0000
|
|
+++ xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/src/Makefile.am 2009-02-02 21:06:55.000000000 +0000
|
|
@@ -24,6 +24,8 @@
|
|
# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
|
|
# _ladir passes a dummy rpath to libtool so the thing will actually link
|
|
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
|
|
+AM_CFLAGS = $(XORG_CFLAGS)
|
|
+
|
|
@DRIVER_NAME@_drv_la_LTLIBRARIES = @DRIVER_NAME@_drv.la
|
|
@DRIVER_NAME@_drv_la_LDFLAGS = -module -avoid-version
|
|
@DRIVER_NAME@_drv_ladir = @inputdir@
|
|
diff -ruN -x .gitignore -x .cvsignore xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/src/xf86Elo.c xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/src/xf86Elo.c
|
|
--- xf86-input-elographics-37cd09e99c7f5fa4ce7511b8ed171a3ae130300f/src/xf86Elo.c 2008-10-21 05:03:43.000000000 +0000
|
|
+++ xf86-input-elographics-c97c9f470636e6caf4374a6930e5fe380f58b8bb/src/xf86Elo.c 2009-02-02 21:06:55.000000000 +0000
|
|
@@ -970,7 +970,7 @@
|
|
***************************************************************************
|
|
*/
|
|
static LocalDevicePtr
|
|
-xf86EloAllocate(InputDriverPtr drv)
|
|
+xf86EloAllocate(InputDriverPtr drv, IDevPtr dev)
|
|
{
|
|
LocalDevicePtr local;
|
|
EloPrivatePtr priv;
|
|
@@ -1002,7 +1002,7 @@
|
|
priv->packet_buf_p = 0;
|
|
priv->swap_axes = 0;
|
|
|
|
- local->name = XI_TOUCHSCREEN;
|
|
+ local->name = xstrdup(dev->identifier);
|
|
local->flags = 0 /* XI86_NO_OPEN_ON_INIT */;
|
|
local->device_control = xf86EloControl;
|
|
local->read_input = xf86EloReadInput;
|
|
@@ -1029,12 +1029,8 @@
|
|
{
|
|
EloPrivatePtr priv = (EloPrivatePtr) local->private;
|
|
|
|
- xf86EloControl(local->dev, DEVICE_OFF);
|
|
-
|
|
xfree(priv->input_dev);
|
|
xfree(priv);
|
|
- xfree(local->name);
|
|
- xfree(local);
|
|
|
|
xf86DeleteInput(local, 0);
|
|
}
|
|
@@ -1064,7 +1060,7 @@
|
|
Model* model;
|
|
|
|
|
|
- local = xf86EloAllocate(drv);
|
|
+ local = xf86EloAllocate(drv, dev);
|
|
if (!local) {
|
|
return NULL;
|
|
}
|