mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
37 lines
1.1 KiB
Diff
37 lines
1.1 KiB
Diff
From 9493c9b79dc541ec9e0fd73c6d87bdf8d30aaa90 Mon Sep 17 00:00:00 2001
|
|
From: Cole Robinson <crobinso@redhat.com>
|
|
Date: Mon, 1 Aug 2022 15:20:38 -0400
|
|
Subject: [PATCH] lxc: containter: fix build with glibc 2.36
|
|
|
|
With glibc 2.36, sys/mount.h and linux/mount.h conflict:
|
|
https://sourceware.org/glibc/wiki/Release/2.36#Usage_of_.3Clinux.2Fmount.h.3E_and_.3Csys.2Fmount.h.3E
|
|
|
|
lxc_container.c imports sys/mount.h and linux/fs.h, which pulls in
|
|
linux/mount.h.
|
|
|
|
linux/fs.h isn't required here though. glibc sys/mount.h has had
|
|
MS_MOVE since 2.12 in 2010
|
|
|
|
Reviewed-by: Erik Skultety <eskultet@redhat.com>
|
|
Signed-off-by: Cole Robinson <crobinso@redhat.com>
|
|
---
|
|
src/lxc/lxc_container.c | 3 ---
|
|
1 file changed, 3 deletions(-)
|
|
|
|
diff --git a/src/lxc/lxc_container.c b/src/lxc/lxc_container.c
|
|
index b5278831da..a5401c2186 100644
|
|
--- a/src/lxc/lxc_container.c
|
|
+++ b/src/lxc/lxc_container.c
|
|
@@ -33,9 +33,6 @@
|
|
/* Yes, we want linux private one, for _syscall2() macro */
|
|
#include <linux/unistd.h>
|
|
|
|
-/* For MS_MOVE */
|
|
-#include <linux/fs.h>
|
|
-
|
|
#if WITH_CAPNG
|
|
# include <cap-ng.h>
|
|
#endif
|
|
--
|
|
GitLab
|
|
|