mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
67 lines
2.2 KiB
Diff
67 lines
2.2 KiB
Diff
diff '--color=auto' -Naur sensors-applet.orig/autogen.sh sensors-applet/autogen.sh
|
|
--- sensors-applet.orig/autogen.sh 2024-04-19 23:28:48.121005602 +0200
|
|
+++ sensors-applet/autogen.sh 2024-04-19 23:32:38.141508669 +0200
|
|
@@ -1,21 +1,38 @@
|
|
#!/bin/sh
|
|
# Run this to generate all the initial makefiles, etc.
|
|
+test -n "$srcdir" || srcdir=$(dirname "$0")
|
|
+test -n "$srcdir" || srcdir=.
|
|
|
|
-srcdir=`dirname $0`
|
|
-test -z "$srcdir" && srcdir=.
|
|
+olddir=$(pwd)
|
|
|
|
-PKG_NAME="sensors-applet"
|
|
+cd $srcdir
|
|
|
|
-(test -f $srcdir/configure.ac) || {
|
|
- echo -n "**Error**: Directory "\`$srcdir\'" does not look like the"
|
|
- echo " top-level $PKG_NAME directory"
|
|
- exit 1
|
|
+(test -f configure.ac) || {
|
|
+ echo "*** ERROR: Directory '$srcdir' does not look like the top-level project directory ***"
|
|
+ exit 1
|
|
}
|
|
|
|
-which gnome-autogen.sh || {
|
|
- echo -n "ERROR: gnome-autogen.sh not found in path: "
|
|
- echo "Please install gnome-common before running this script"
|
|
- exit 1
|
|
-}
|
|
+# shellcheck disable=SC2016
|
|
+PKG_NAME=$(autoconf --trace 'AC_INIT:$1' configure.ac)
|
|
+
|
|
+if [ "$#" = 0 -a "x$NOCONFIGURE" = "x" ]; then
|
|
+ echo "*** WARNING: I am going to run 'configure' with no arguments." >&2
|
|
+ echo "*** If you wish to pass any to it, please specify them on the" >&2
|
|
+ echo "*** '$0' command line." >&2
|
|
+ echo "" >&2
|
|
+fi
|
|
+
|
|
+autoreconf --verbose --force --install || exit 1
|
|
+
|
|
+cd "$olddir"
|
|
+if [ "$NOCONFIGURE" = "" ]; then
|
|
+ $srcdir/configure "$@" || exit 1
|
|
|
|
-REQUIRED_AUTOMAKE_VERSION=1.7 USE_GNOME2_MACROS=1 . gnome-autogen.sh
|
|
+ if [ "$1" = "--help" ]; then
|
|
+ exit 0
|
|
+ else
|
|
+ echo "Now type 'make' to compile $PKG_NAME" || exit 1
|
|
+ fi
|
|
+else
|
|
+ echo "Skipping configure process."
|
|
+fi
|
|
diff '--color=auto' -Naur sensors-applet.orig/configure.ac sensors-applet/configure.ac
|
|
--- sensors-applet.orig/configure.ac 2024-04-19 23:28:48.214343415 +0200
|
|
+++ sensors-applet/configure.ac 2024-04-19 23:30:24.755320189 +0200
|
|
@@ -252,8 +252,6 @@
|
|
AC_MSG_ERROR([xsltproc executable not found in your path - should be installed with libxslt])
|
|
fi
|
|
|
|
-GNOME_COMPILE_WARNINGS(maximum)
|
|
-
|
|
YELP_HELP_INIT
|
|
|
|
# ==================== plugin stuff ================== #
|