mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
11 lines
564 B
Diff
11 lines
564 B
Diff
--- trunk/mcs/class/System.Web.Services/System.Web.Services.Description/BasicProfileChecker.cs 2008/07/01 20:17:46 107006
|
|
+++ trunk/mcs/class/System.Web.Services/System.Web.Services.Description/BasicProfileChecker.cs 2008/10/28 09:32:46 117243
|
|
@@ -177,7 +177,7 @@
|
|
foreach (OperationMessage om in op.Messages) {
|
|
Message msg = ctx.Services.GetMessage (om.Message);
|
|
foreach (MessagePart part in msg.Parts)
|
|
- parts.Add (part,part);
|
|
+ parts [part] = part; // do not use Add() - there could be the same MessagePart instance.
|
|
}
|
|
}
|
|
|