PKGBUILDs/extra/thunderbird/0031-bmo-1873379-fix-libc++-18-ignore-tuple-harder.patch
2024-07-24 11:48:46 +00:00

58 lines
2.2 KiB
Diff

# HG changeset patch
# User Emilio Cobos Álvarez <emilio@crisal.io>
# Date 1705156533 0
# Node ID 9e96d1447f6c77f15bcd1c7fa432cefae4418038
# Parent 23a77d3c25d74ed46ebb77f47fda83c7b6dcdb45
Bug 1873379 - Ignore std::tuple harder. r=firefox-style-system-reviewers,zrhoffman
In libc++ 18 it seems to be in a nested namespace. Make sure to account
for that.
Differential Revision: https://phabricator.services.mozilla.com/D198398
diff --git a/layout/style/ServoBindings.toml b/layout/style/ServoBindings.toml
--- a/layout/style/ServoBindings.toml
+++ b/layout/style/ServoBindings.toml
@@ -361,16 +361,19 @@ allowlist-types = [
"NodeSelectorFlags",
]
opaque-types = [
"mozilla::StyleThinArc", # https://github.com/rust-lang/rust-bindgen/issues/1557
"std::pair__PCCP",
"std::namespace::atomic___base", "std::atomic__My_base",
"std::atomic",
"std::atomic___base",
+ "std::tuple.*", # Causes "Cannot find type _Pred in this scope" error on mac, like rust-skia#571
+ "std::.*::tuple.*",
+
# We want everything but FontVariation and Float to be opaque but we don't
# have negative regexes.
"mozilla::gfx::(.{0,4}|.{6,12}|.{14,}|([^F][^o][^n][^t][^V][^a][^r][^i][^a][^t][^i][^o][^n])|([^F][^l][^o][^a][^t]))",
"mozilla::dom::Sequence",
"mozilla::SmallPointerArray",
"mozilla::dom::Optional",
"mozilla::dom::OwningNodeOrString_Value",
"mozilla::dom::Nullable",
@@ -386,18 +389,16 @@ opaque-types = [
"mozilla::detail::PointerType",
"mozilla::HashSet",
"mozilla::Pair",
"mozilla::Pair_Base",
"mozilla::ScrollAxis", # <- For some reason the alignment of this is 4
# for clang.
"mozilla::SeenPtrs",
"mozilla::SupportsWeakPtr",
- "std::tuple",
- "std::tuple_.*", # Causes "Cannot find type _Pred in this scope" error on mac, like rust-skia#571
"SupportsWeakPtr",
"mozilla::detail::WeakReference",
"mozilla::WeakPtr",
"nsWritingIterator_reference", "nsReadingIterator_reference",
"nsTObserverArray", # <- Inherits from nsAutoTObserverArray<T, 0>
"mozilla::DoublyLinkedList",
"mozilla::SafeDoublyLinkedList",
"nsTHashtable", # <- Inheriting from inner typedefs that clang