mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
27 lines
873 B
Diff
27 lines
873 B
Diff
From 6cdbb9492c27ba80a7120266817775880f273046 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Sun, 28 Dec 2014 22:32:15 -0700
|
|
Subject: [PATCH 3/8] makechrootpkg: distcc
|
|
|
|
---
|
|
makechrootpkg.in | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
|
index bf81573..6f201b2 100644
|
|
--- a/makechrootpkg.in
|
|
+++ b/makechrootpkg.in
|
|
@@ -232,7 +232,9 @@ _chrootbuild() {
|
|
# use "$" in arguments to commands with "sudo -i". ${foo} or
|
|
# ${1} is OK, but $foo or $1 isn't.
|
|
# https://bugzilla.sudo.ws/show_bug.cgi?id=765
|
|
- sudo -iu builduser bash -c 'cd /startdir; makepkg "$@"' -bash "$@"
|
|
+ mkdir /build/.distcc
|
|
+ chown builduser /build/.distcc
|
|
+ sudo -iu builduser DISTCC_IO_TIMEOUT=1200 DISTCC_DIR='/build/.distcc' bash -c 'cd /startdir; makepkg "$@"' -bash "$@"
|
|
}
|
|
|
|
_chrootnamcap() {
|
|
--
|
|
2.14.1
|
|
|