mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
27 lines
685 B
Diff
27 lines
685 B
Diff
From 7d71124991030f99965e6e6aaed421115f185adb Mon Sep 17 00:00:00 2001
|
|
From: Ricardo Ribalda Delgado <ricardo.ribalda@...>
|
|
Date: Mon, 9 Feb 2015 13:51:56 +0100
|
|
Subject: [PATCH] ioctl.c: Fix build on 3.19
|
|
|
|
get_unused_fd() MACRO has been removed on kernel 3.19. Replace by the
|
|
actual output of the macro.
|
|
|
|
Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@...>
|
|
---
|
|
ioctl.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/ioctl.c b/ioctl.c
|
|
--- a/ioctl.c
|
|
+++ b/ioctl.c
|
|
@@ -546,7 +546,7 @@
|
|
clonefd(struct file *filp)
|
|
{
|
|
int ret;
|
|
- ret = get_unused_fd();
|
|
+ ret = get_unused_fd_flags(0);
|
|
if (ret >= 0) {
|
|
get_file(filp);
|
|
fd_install(ret, filp);
|
|
--
|
|
2.1.4
|