mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
17 lines
556 B
Diff
17 lines
556 B
Diff
After https://github.com/boostorg/logic/commit/23cd89d4c80f build fails:
|
|
|
|
sfx2/source/appl/shutdownicon.cxx:170:12: error: no viable conversion from returned value of type 'boost::logic::tribool' to function return type 'bool'
|
|
return loaded;
|
|
^~~~~~
|
|
|
|
--- sfx2/source/appl/shutdownicon.cxx.orig 2018-06-19 22:27:30 UTC
|
|
+++ sfx2/source/appl/shutdownicon.cxx
|
|
@@ -167,7 +167,7 @@ bool LoadModule()
|
|
#endif // ENABLE_QUICKSTART_APPLET
|
|
}
|
|
assert(!boost::logic::indeterminate(loaded));
|
|
- return loaded;
|
|
+ return bool{loaded};
|
|
}
|
|
|
|
}
|