PKGBUILDs/community/freeimage/freeimage-libraw-0.21.patch
2022-12-19 22:15:55 +00:00

13 lines
748 B
Diff

diff -ru FreeImage.orig/Source/FreeImage/PluginRAW.cpp FreeImage/Source/FreeImage/PluginRAW.cpp
--- FreeImage.orig/Source/FreeImage/PluginRAW.cpp 2022-12-18 21:57:11.447801357 +0100
+++ FreeImage/Source/FreeImage/PluginRAW.cpp 2022-12-18 21:58:05.103433138 +0100
@@ -687,7 +687,7 @@
// --------------------------------------------
// (-s [0..N-1]) Select one raw image from input file
- RawProcessor->imgdata.params.shot_select = 0;
+ RawProcessor->imgdata.rawparams.shot_select = 0;
// (-w) Use camera white balance, if possible (otherwise, fallback to auto_wb)
RawProcessor->imgdata.params.use_camera_wb = 1;
// (-M) Use any color matrix from the camera metadata. This option only affects Olympus, Leaf, and Phase One cameras.