mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
36 lines
1.7 KiB
Diff
36 lines
1.7 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
|
|
Date: Thu, 6 May 2021 20:14:58 +0200
|
|
Subject: [PATCH] bootstrap: Change libexec dir
|
|
|
|
---
|
|
src/bootstrap/src/core/build_steps/dist.rs | 2 +-
|
|
src/bootstrap/src/core/build_steps/tool.rs | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/src/bootstrap/src/core/build_steps/dist.rs b/src/bootstrap/src/core/build_steps/dist.rs
|
|
index 770a5cdb232d..d115a615774c 100644
|
|
--- a/src/bootstrap/src/core/build_steps/dist.rs
|
|
+++ b/src/bootstrap/src/core/build_steps/dist.rs
|
|
@@ -424,7 +424,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
|
},
|
|
builder.kind,
|
|
) {
|
|
- builder.install(&ra_proc_macro_srv, &image.join("libexec"), 0o755);
|
|
+ builder.install(&ra_proc_macro_srv, &image.join("lib"), 0o755);
|
|
}
|
|
|
|
let libdir_relative = builder.libdir_relative(compiler);
|
|
diff --git a/src/bootstrap/src/core/build_steps/tool.rs b/src/bootstrap/src/core/build_steps/tool.rs
|
|
index 994f0bef0dc7..075f3e9e4166 100644
|
|
--- a/src/bootstrap/src/core/build_steps/tool.rs
|
|
+++ b/src/bootstrap/src/core/build_steps/tool.rs
|
|
@@ -681,7 +681,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
|
|
|
|
// Copy `rust-analyzer-proc-macro-srv` to `<sysroot>/libexec/`
|
|
// so that r-a can use it.
|
|
- let libexec_path = builder.sysroot(self.compiler).join("libexec");
|
|
+ let libexec_path = builder.sysroot(self.compiler).join("lib");
|
|
t!(fs::create_dir_all(&libexec_path));
|
|
builder.copy_link(&path, &libexec_path.join("rust-analyzer-proc-macro-srv"));
|
|
|