mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
41 lines
872 B
Diff
41 lines
872 B
Diff
--- cpuburn-1.4.orig/burnP6.S
|
|
+++ cpuburn-1.4/burnP6.S
|
|
@@ -69,6 +69,7 @@
|
|
push %eax # *BSD syscall
|
|
int $0x80
|
|
#endif
|
|
+.data # Data allocation
|
|
.align 32,0
|
|
half: .long 0x7fffffff,0
|
|
e: .long 0xffffffff,0x3fdfffff
|
|
--- cpuburn-1.4.orig/burnK6.S
|
|
+++ cpuburn-1.4/burnK6.S
|
|
@@ -68,6 +68,7 @@
|
|
push %eax
|
|
int $0x80
|
|
#endif
|
|
+.data # Data allocation
|
|
.align 32,0
|
|
half: .long 0x7fffffff,0
|
|
e: .long 0xffffffff,0x3fdfffff
|
|
--- cpuburn-1.4.orig/Makefile
|
|
+++ cpuburn-1.4/Makefile
|
|
@@ -1,3 +1,3 @@
|
|
all : burnP5 burnP6 burnK6 burnK7 burnBX burnMMX
|
|
.S:
|
|
- gcc -s -nostdlib -o $@ $<
|
|
+ gcc -m32 -s -nostdlib -static -o $@ $<
|
|
--- cpuburn-1.4.orig/burnK7.S
|
|
+++ cpuburn-1.4/burnK7.S
|
|
@@ -74,10 +74,9 @@
|
|
push %eax
|
|
int $0x80
|
|
#endif
|
|
+.data # Data allocation
|
|
.align 32,0
|
|
.fill 64
|
|
half: .long 0x7fffffff,0
|
|
e: .long 0xffffffff,0x3fdfffff
|
|
rt: .long 0xffffffff,0x3fefffff
|
|
-
|
|
-
|