PKGBUILDs/extra/gnuchess/gnuchess-glibc210.patch
2009-10-09 21:23:22 -05:00

39 lines
1.1 KiB
Diff

--- src/common.h.old 2009-05-28 10:26:58.000000000 +0200
+++ src/common.h 2009-05-28 11:03:31.000000000 +0200
@@ -745,7 +745,7 @@
* Input routine, initialized to one of the specific
* input routines. The given argument is the prompt.
*/
-void (*getline) (char *);
+void (*mygetline) (char *);
#define MAXSTR 128
extern char inputstr[MAXSTR];
--- src/input.c.old 2009-05-28 10:27:06.000000000 +0200
+++ src/input.c 2009-05-28 11:04:38.000000000 +0200
@@ -127,7 +127,7 @@
(RealGameCnt+1)/2 + 1 );
}
pthread_mutex_lock(&input_mutex);
- getline(prompt);
+ mygetline(prompt);
input_status = INPUT_AVAILABLE;
pthread_cond_signal(&input_cond);
pthread_mutex_unlock(&input_mutex);
@@ -173,13 +173,13 @@
{
#ifdef HAVE_LIBREADLINE
if (isatty(STDIN_FILENO)) {
- getline = getline_readline;
+ mygetline = getline_readline;
using_history();
} else {
- getline = getline_standard;
+ mygetline = getline_standard;
}
#else
- getline = getline_standard;
+ mygetline = getline_standard;
#endif
/* Start input thread */
pthread_create(&input_thread, NULL, input_func, NULL);