PKGBUILDs/extra/gpart/gpart-0.1h-no-_syscall.patch
2009-10-09 21:23:22 -05:00

15 lines
373 B
Diff

use syscall() rather than _syscall#()
http://bugs.gentoo.org/163800
--- src/l64seek.c
+++ src/l64seek.c
@@ -27,7 +27,7 @@
static int osptr = -1;
#if defined(__linux__) && defined(__i386__) && ! defined(__PIC__)
-_syscall5(int,_llseek,uint,fd,ulong,hi,ulong,lo,loff_t *,res,uint,wh)
+#define _llseek(fd,hi,lo,res,wh) syscall(__NR__llseek,fd,hi,lo,res,wh)
#endif