mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
39 lines
1.1 KiB
Diff
39 lines
1.1 KiB
Diff
diff -Naur libmikmod-3.1.12-old/playercode/mplayer.c libmikmod-3.1.12/playercode/mplayer.c
|
|
--- libmikmod-3.1.12-old/playercode/mplayer.c 2007-12-15 19:26:28.000000000 +1000
|
|
+++ libmikmod-3.1.12/playercode/mplayer.c 2009-01-21 18:53:59.000000000 +1000
|
|
@@ -2318,7 +2318,7 @@
|
|
SAMPLE *s;
|
|
|
|
mod->totalchn=mod->realchn=0;
|
|
- for (channel=0;channel<md_sngchn;channel++) {
|
|
+ for (channel=0;channel<pf->numchn;channel++) {
|
|
aout=&mod->voice[channel];
|
|
i=aout->main.i;
|
|
s=aout->main.s;
|
|
@@ -3086,7 +3086,7 @@
|
|
pf->patbrk=0;
|
|
pf->vbtick=pf->sngspd;
|
|
|
|
- for (t=0;t<md_sngchn;t++) {
|
|
+ for (t=0;t<pf->numchn;t++) {
|
|
Voice_Stop_internal(t);
|
|
pf->voice[t].main.i=NULL;
|
|
pf->voice[t].main.s=NULL;
|
|
@@ -3111,7 +3111,7 @@
|
|
pf->patbrk=0;
|
|
pf->vbtick=pf->sngspd;
|
|
|
|
- for (t=0;t<md_sngchn;t++) {
|
|
+ for (t=0;t<pf->numchn;t++) {
|
|
Voice_Stop_internal(t);
|
|
pf->voice[t].main.i=NULL;
|
|
pf->voice[t].main.s=NULL;
|
|
@@ -3138,7 +3138,7 @@
|
|
pf->sngpos=pos;
|
|
pf->vbtick=pf->sngspd;
|
|
|
|
- for (t=0;t<md_sngchn;t++) {
|
|
+ for (t=0;t<pf->numchn;t++) {
|
|
Voice_Stop_internal(t);
|
|
pf->voice[t].main.i=NULL;
|
|
pf->voice[t].main.s=NULL;
|