mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
57 lines
1.9 KiB
Diff
57 lines
1.9 KiB
Diff
--- configure.orig 2008-01-30 13:06:35.000000000 +0100
|
|
+++ configure 2008-01-30 13:06:45.000000000 +0100
|
|
@@ -26894,18 +26894,18 @@
|
|
echo $ECHO_N "checking what extra warning flags to pass to the C compiler... $ECHO_C" >&6; }
|
|
if test ${GCC}x = yesx; then
|
|
warnFLAGS=
|
|
- CFLAGS="${CFLAGS} -g2 -Wall"
|
|
+ CFLAGS="${CFLAGS}"
|
|
# Check whether --enable-error-on-warning was given.
|
|
if test "${enable_error_on_warning+set}" = set; then
|
|
enableval=$enable_error_on_warning; case "${enableval}" in
|
|
- yes) warnFLAGS="${warnFLAGS} -Werror" ;;
|
|
+ yes) warnFLAGS="${warnFLAGS}" ;;
|
|
no) ;;
|
|
*) { { echo "$as_me:$LINENO: error: bad value ${enableval} for --enable-error-on-warning" >&5
|
|
echo "$as_me: error: bad value ${enableval} for --enable-error-on-warning" >&2;}
|
|
{ (exit 1); exit 1; }; } ;;
|
|
esac
|
|
else
|
|
- warnFLAGS="${warnFLAGS} -Werror"
|
|
+ warnFLAGS="${warnFLAGS}"
|
|
fi
|
|
|
|
GCC_VERSION=`${CC} -dumpversion`
|
|
@@ -26913,10 +26913,10 @@
|
|
# This is gcc >= 3.x.x
|
|
if test `echo ${GCC_VERSION} | cut -d. -f2` -ge 4; then
|
|
# This is gcc >= 3.4.x
|
|
- warnFLAGS="${warnFLAGS} -Wdeclaration-after-statement"
|
|
+ warnFLAGS="${warnFLAGS}"
|
|
else if test `echo ${GCC_VERSION} | cut -d. -f1` -ge 4; then
|
|
# This is gcc == 4.x.x
|
|
- warnFLAGS="${warnFLAGS} -Wdeclaration-after-statement -Wno-pointer-sign"
|
|
+ warnFLAGS="${warnFLAGS}"
|
|
fi
|
|
fi
|
|
fi
|
|
@@ -26934,19 +26934,6 @@
|
|
enableval=$enable_compile_warnings; set_compile_warnings=yes
|
|
fi
|
|
|
|
-
|
|
-if test "$GCC" = "yes" -a "$set_compile_warnings" != "no"; then
|
|
- warnFLAGS="$warnFLAGS -Wcast-align -Wsign-compare \
|
|
- -Wmissing-prototypes -Wmissing-declarations -Werror -Wmissing-include-dirs \
|
|
- -Wstrict-prototypes -Winline -Wnested-externs -Wpointer-arith \
|
|
- -Wmissing-field-initializers"
|
|
-# LDFLAGS="$LDFLAGS -Wl,-z,defs"
|
|
-fi
|
|
-
|
|
-
|
|
-
|
|
-
|
|
-
|
|
DATADIR=`eval echo $datadir`
|
|
QSF_SCHEMA_DIR=`eval echo $DATADIR`"/xml/qof/qsf"
|
|
|