PKGBUILDs/core/linux-armv5-rc/0002-at91-ariag25-updates.patch
2020-07-06 00:25:03 +00:00

94 lines
2.2 KiB
Diff

From 6560c5c50e087dccbd91dd4b2e918a76efe5c7f2 Mon Sep 17 00:00:00 2001
From: Douglas Gilbert <[mailto:dgilbert@interlog.com]>
Date: Mon, 12 Aug 2013 10:36:25 -0500
Subject: [PATCH 2/9] at91: ariag25 updates
v2: dropped at91sam9x5 usart fix, as merged mainline
Signed-off-by: Douglas Gilbert <dgilbert@interlog.com>
Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
---
arch/arm/boot/dts/at91-ariag25.dts | 39 +++++++++++++++++++++++++++---
1 file changed, 36 insertions(+), 3 deletions(-)
diff --git a/arch/arm/boot/dts/at91-ariag25.dts b/arch/arm/boot/dts/at91-ariag25.dts
index dbfefef2869d..2f20575c7ccb 100644
--- a/arch/arm/boot/dts/at91-ariag25.dts
+++ b/arch/arm/boot/dts/at91-ariag25.dts
@@ -82,7 +82,7 @@ &macb0 {
* following can be overwritten by bootloader:
* for example u-boot 'ftd set' command
*/
- local-mac-address = [00 00 00 00 00 00];
+ local-mac-address = [00 04 25 ef 00 00];
status = "okay";
};
@@ -104,7 +104,7 @@ slot@0 {
&pinctrl {
w1_0 {
pinctrl_w1_0: w1_0-0 {
- atmel,pins = <0 21 0x0 0x1>; /* PA21 PIO, pull-up */
+ atmel,pins = <AT91_PIOA 21 AT91_PERIPH_GPIO AT91_PINCTRL_PULL_UP>;
};
};
};
@@ -113,6 +113,11 @@ &rtc {
status = "okay";
};
+&watchdog {
+ /* timeout-sec = <14>; */
+ status = "okay";
+};
+
&tcb0 {
timer@0 {
compatible = "atmel,tcb-timer";
@@ -131,13 +136,41 @@ timer@1 {
* Change to "okay" if you need additional serial ports
*/
&uart0 {
- status = "disabled";
+ status = "okay";
};
&uart1 {
status = "disabled";
};
+&spi0 {
+ status = "okay";
+ cs-gpios = <&pioA 14 0>, <0>, <0>, <0>;
+ anything@0 {
+ compatible = "spidev";
+ // spi-max-frequency = <50000000>; // 50 MHz
+ spi-max-frequency = <5000000>; // 5 MHz
+ reg = <0>;
+ };
+ // m25p80@0 {
+ // compatible = "spidev";
+ // spi-max-frequency = <50000000>;
+ // reg = <0>;
+ // };
+
+ mmc-slot@0 {
+ compatible = "mmc-spi-slot";
+ reg = <0>;
+ voltage-ranges = <3300 3300>;
+ // Use one of next 3 lines, comment out other 2
+ gpios = <&pioA 26 0>; /* CD to PA26 */
+ // broken-cd;
+ // non-removable;
+ cd-inverted;
+ spi-max-frequency = <8000000>;
+ };
+};
+
&usart0 {
pinctrl-0 = <&pinctrl_usart0
&pinctrl_usart0_rts
--
2.26.1