PKGBUILDs/aur/par2cmdline/04-offset-must-always-be-updated-even-when-progress-is-.patch
2011-06-09 17:56:14 -04:00

14 lines
365 B
Diff

--- a/par2creatorsourcefile.cpp
+++ b/par2creatorsourcefile.cpp
@@ -224,6 +224,10 @@ bool Par2CreatorSourceFile::Open(CommandLine::NoiseLevel noiselevel, const Comma
cout << newfraction/10 << '.' << newfraction%10 << "%\r" << flush;
}
}
+ else
+ {
+ offset += want;
+ }
}
// Did we finish the last block