PKGBUILDs/extra/chromium/0002-Run-blink-bindings-generation-single-threaded.patch
2021-07-22 12:33:35 +00:00

26 lines
892 B
Diff

From b6540b7ab88e5c47ee0978de312cf0a997d9b981 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 2 Feb 2021 13:58:59 -0700
Subject: [PATCH 2/3] Run blink bindings generation single threaded
When not single threaded this process will eat all the RAM.
---
third_party/blink/renderer/bindings/BUILD.gn | 1 +
1 file changed, 1 insertion(+)
diff --git a/third_party/blink/renderer/bindings/BUILD.gn b/third_party/blink/renderer/bindings/BUILD.gn
index 385c9d0c45de..6b814e5cf741 100644
--- a/third_party/blink/renderer/bindings/BUILD.gn
+++ b/third_party/blink/renderer/bindings/BUILD.gn
@@ -187,6 +187,7 @@ template("generate_bindings") {
outputs = invoker.outputs
args = [
+ "--single_process",
"--web_idl_database",
rebase_path(web_idl_database, root_build_dir),
"--root_src_dir",
--
2.32.0