mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
47 lines
2.1 KiB
Diff
47 lines
2.1 KiB
Diff
From: Didier Raboud <odyx@debian.org>
|
|
Date: Tue, 21 Aug 2018 18:18:10 +0200
|
|
Subject: Remove ImageProcessor binary installs
|
|
|
|
---
|
|
Makefile.am | 14 ++------------
|
|
1 file changed, 2 insertions(+), 12 deletions(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index c707e1e..0d8b692 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -167,7 +167,7 @@ if !HPLIP_CLASS_DRIVER
|
|
dist_hplip_SCRIPTS = hpssd.py __init__.py hpdio.py
|
|
endif #HPLIP_CLASS_DRIVER
|
|
|
|
-dist_noinst_DATA += prnt/drv/hpijs.drv.in.template prnt/drv/hpcups.drv.in.template prnt/hpcups/libImageProcessor-x86_64.so prnt/hpcups/libImageProcessor-x86_32.so
|
|
+dist_noinst_DATA += prnt/drv/hpijs.drv.in.template prnt/drv/hpcups.drv.in.template
|
|
dist_noinst_SCRIPTS += dat2drv.py install.py hplip-install init-suse-firewall init-iptables-firewall class_rpm_build.sh hplipclassdriver.spec createPPD.sh Makefile_dat2drv hpijs-drv
|
|
|
|
if !HPLIP_CLASS_DRIVER
|
|
@@ -595,7 +595,7 @@ hpcups_SOURCES = prnt/hpcups/HPCupsFilter.cpp prnt/hpcups/HPCupsFilter.h prnt/hp
|
|
prnt/hpcups/ImageProcessor.h
|
|
|
|
hpcups_CXXFLAGS = $(APDK_ENDIAN_FLAG) $(DBUS_CFLAGS)
|
|
-hpcups_LDADD = -L./prnt/hpcups/ -ljpeg -ldl -lImageProcessor -lcups -lcupsimage -lz $(DBUS_LIBS)
|
|
+hpcups_LDADD = -L./prnt/hpcups/ -ljpeg -ldl -lcups -lcupsimage -lz $(DBUS_LIBS)
|
|
#else
|
|
#hpcupsdir = $(cupsfilterdir)
|
|
#hpcups_PROGRAMS = hpcups
|
|
@@ -687,16 +687,6 @@ endif #HPLIP_CLASS_DRIVER
|
|
|
|
install-data-hook:
|
|
if HPLIP_BUILD
|
|
- if [ \( "$(UNAME)" = "x86_64" -a -d "$(libdir)/" \) ]; then \
|
|
- cp prnt/hpcups/libImageProcessor-x86_64.so $(libdir)/ ; \
|
|
- chmod 775 $(libdir)/libImageProcessor-x86_64.so ; \
|
|
- ln -sf $(libdir)/libImageProcessor-x86_64.so $(libdir)/libImageProcessor.so ; \
|
|
- fi; \
|
|
- if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/" \) ]; then \
|
|
- cp prnt/hpcups/libImageProcessor-x86_32.so $(libdir)/ ; \
|
|
- chmod 775 $(libdir)/libImageProcessor-x86_32.so ; \
|
|
- ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \
|
|
- fi
|
|
if !HPLIP_CLASS_DRIVER
|
|
# If scanner build, add hpaio entry to sane dll.conf.
|
|
if [ "$(scan_build)" = "yes" ]; then \
|