mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
56 lines
2.7 KiB
Diff
56 lines
2.7 KiB
Diff
First noticed on Fedora Rawhide:
|
||
|
||
tests/bpf.c: In function ‘epoll_pwait_loop’:
|
||
tests/bpf.c:36:17: error: argument 2 null where non-null expected [-Werror=nonnull]
|
||
36 | epoll_pwait(-(i + 1), NULL, 0, 0, NULL);
|
||
| ^~~~~~~~~~~
|
||
In file included from tests/bpf.c:5:
|
||
/usr/include/sys/epoll.h:134:12: note: in a call to function ‘epoll_pwait’ declared ‘nonnull’
|
||
134 | extern int epoll_pwait (int __epfd, struct epoll_event *__events,
|
||
| ^~~~~~~~~~~
|
||
|
||
[perfbuilder@27cfe44d67ed perf-6.5.0-rc2]$ gcc -v
|
||
Using built-in specs.
|
||
COLLECT_GCC=gcc
|
||
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/13/lto-wrapper
|
||
OFFLOAD_TARGET_NAMES=nvptx-none
|
||
OFFLOAD_TARGET_DEFAULT=1
|
||
Target: x86_64-redhat-linux
|
||
Configured with: ../configure --enable-bootstrap --enable-languages=c,c++,fortran,objc,obj-c++,ada,go,d,m2,lto --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-shared --enable-threads=posix --enable-checking=release --enable-multilib --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-gcc-major-version-only --enable-libstdcxx-backtrace --with-libstdcxx-zoneinfo=/usr/share/zoneinfo --with-linker-hash-style=gnu --enable-plugin --enable-initfini-array --with-isl=/builddir/build/BUILD/gcc-13.2.1-20230728/obj-x86_64-redhat-linux/isl-install --enable-offload-targets=nvptx-none --without-cuda-driver --enable-offload-defaulted --enable-gnu-indirect-function --enable-cet --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux --with-build-config=bootstrap-lto --enable-link-serialization=1
|
||
Thread model: posix
|
||
Supported LTO compression algorithms: zlib zstd
|
||
gcc version 13.2.1 20230728 (Red Hat 13.2.1-1) (GCC)
|
||
[perfbuilder@27cfe44d67ed perf-6.5.0-rc2]$
|
||
|
||
Just add that argument to address this compiler warning.
|
||
|
||
Cc: Adrian Hunter <adrian.hunter@intel.com>
|
||
Cc: Ian Rogers <irogers@google.com>
|
||
Cc: Jiri Olsa <jolsa@kernel.org>
|
||
Cc: Namhyung Kim <namhyung@kernel.org>
|
||
Link: https://lore.kernel.org/lkml/
|
||
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
|
||
---
|
||
tools/perf/tests/bpf.c | 3 ++-
|
||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||
|
||
diff --git a/tools/perf/tests/bpf.c b/tools/perf/tests/bpf.c
|
||
index 31796f2a80f47fb1..9ccecd873ecdd046 100644
|
||
--- a/tools/perf/tests/bpf.c
|
||
+++ b/tools/perf/tests/bpf.c
|
||
@@ -29,11 +29,12 @@
|
||
|
||
static int epoll_pwait_loop(void)
|
||
{
|
||
+ struct epoll_event events;
|
||
int i;
|
||
|
||
/* Should fail NR_ITERS times */
|
||
for (i = 0; i < NR_ITERS; i++)
|
||
- epoll_pwait(-(i + 1), NULL, 0, 0, NULL);
|
||
+ epoll_pwait(-(i + 1), &events, 0, 0, NULL);
|
||
return 0;
|
||
}
|
||
|
||
--
|
||
2.37.1
|