mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
42 lines
1.3 KiB
Diff
42 lines
1.3 KiB
Diff
diff -Naur glibc-old/sysdeps/unix/sysv/linux/i386/clone.S glibc/sysdeps/unix/sysv/linux/i386/clone.S
|
|
--- glibc-old/sysdeps/unix/sysv/linux/i386/clone.S 2009-05-09 13:35:30.000000000 +1000
|
|
+++ glibc/sysdeps/unix/sysv/linux/i386/clone.S 2009-05-23 13:27:46.000000000 +1000
|
|
@@ -120,9 +120,6 @@
|
|
ret
|
|
|
|
L(thread_start):
|
|
- cfi_startproc;
|
|
- /* Clearing frame pointer is insufficient, use CFI. */
|
|
- cfi_undefined (eip);
|
|
/* Note: %esi is zero. */
|
|
movl %esi,%ebp /* terminate the stack frame */
|
|
#ifdef RESET_PID
|
|
@@ -155,7 +152,6 @@
|
|
jmp L(haspid)
|
|
.previous
|
|
#endif
|
|
- cfi_endproc;
|
|
|
|
cfi_startproc
|
|
PSEUDO_END (BP_SYM (__clone))
|
|
diff -Naur glibc-old/sysdeps/unix/sysv/linux/x86_64/clone.S glibc/sysdeps/unix/sysv/linux/x86_64/clone.S
|
|
--- glibc-old/sysdeps/unix/sysv/linux/x86_64/clone.S 2009-05-09 13:35:30.000000000 +1000
|
|
+++ glibc/sysdeps/unix/sysv/linux/x86_64/clone.S 2009-05-23 13:27:46.000000000 +1000
|
|
@@ -89,9 +89,6 @@
|
|
ret
|
|
|
|
L(thread_start):
|
|
- cfi_startproc;
|
|
- /* Clearing frame pointer is insufficient, use CFI. */
|
|
- cfi_undefined (rip);
|
|
/* Clear the frame pointer. The ABI suggests this be done, to mark
|
|
the outermost frame obviously. */
|
|
xorl %ebp, %ebp
|
|
@@ -116,7 +113,6 @@
|
|
/* Call exit with return value from function call. */
|
|
movq %rax, %rdi
|
|
call HIDDEN_JUMPTARGET (_exit)
|
|
- cfi_endproc;
|
|
|
|
cfi_startproc;
|
|
PSEUDO_END (BP_SYM (__clone))
|