mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
20 lines
1 KiB
Diff
20 lines
1 KiB
Diff
--- a2jmidid-8/sigsegv.c.orig 2014-10-27 00:55:18.105347411 +0000
|
|
+++ a2jmidid-8/sigsegv.c 2014-10-27 00:56:07.209296207 +0000
|
|
@@ -91,7 +91,7 @@
|
|
a2j_error("info.si_errno = %d", info->si_errno);
|
|
a2j_error("info.si_code = %d (%s)", info->si_code, si_codes[info->si_code]);
|
|
a2j_error("info.si_addr = %p", info->si_addr);
|
|
-#if !defined(__alpha__) && !defined(__ia64__) && !defined(__FreeBSD_kernel__) && !defined(__arm__) && !defined(__hppa__) && !defined(__sh__)
|
|
+#if !defined(__alpha__) && !defined(__ia64__) && !defined(__FreeBSD_kernel__) && !defined(__arm__) && !defined(__hppa__) && !defined(__sh__) && !defined(__aarch64__)
|
|
for(i = 0; i < NGREG; i++)
|
|
a2j_error("reg[%02d] = 0x" REGFORMAT, i,
|
|
#if defined(__powerpc__)
|
|
@@ -102,7 +102,7 @@
|
|
ucontext->uc_mcontext.gregs[i]
|
|
#endif
|
|
);
|
|
-#endif /* alpha, ia64, kFreeBSD, arm, hppa */
|
|
+#endif /* alpha, ia64, kFreeBSD, arm, hppa, aarch64 */
|
|
|
|
#if defined(SIGSEGV_STACK_X86) || defined(SIGSEGV_STACK_IA64)
|
|
# if defined(SIGSEGV_STACK_IA64)
|