mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
28 lines
886 B
Diff
28 lines
886 B
Diff
From 60b367ea5b8a972975e725ecaaa864331fe75787 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Wed, 24 Jun 2015 20:22:19 -0600
|
|
Subject: [PATCH 4/5] fix for rt6_route_rcv changes
|
|
|
|
Broke in chromiumos commit a71e01a88666c143ab242ae1e04d6ddfc9dd14cd.
|
|
|
|
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
---
|
|
net/ipv6/route.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/net/ipv6/route.c b/net/ipv6/route.c
|
|
index 6ee82ce..0a6a299 100644
|
|
--- a/net/ipv6/route.c
|
|
+++ b/net/ipv6/route.c
|
|
@@ -749,7 +749,7 @@ int rt6_route_rcv(struct net_device *dev, u8 *opt, int len,
|
|
if (rinfo->prefix_len == 0)
|
|
rt = rt6_get_dflt_router(gwaddr, dev);
|
|
else
|
|
- rt = rt6_get_route_info(net, prefix, rinfo->prefix_len, gwaddr);
|
|
+ rt = rt6_get_route_info(dev, prefix, rinfo->prefix_len, gwaddr);
|
|
|
|
if (rt && !lifetime) {
|
|
ip6_del_rt(rt);
|
|
--
|
|
2.4.3
|
|
|