mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
21 lines
757 B
Diff
21 lines
757 B
Diff
diff -urN a/src/chm_lib.c b/src/chm_lib.c
|
|
--- a/src/chm_lib.c 2009-05-23 08:43:31.000000000 -0600
|
|
+++ b/src/chm_lib.c 2015-07-18 14:15:00.588557608 -0600
|
|
@@ -153,7 +153,7 @@
|
|
/* Sparc */
|
|
/* MIPS */
|
|
/* PPC */
|
|
-#elif __i386__ || __sun || __sgi || __ppc__
|
|
+#elif __i386__ || __sun || __sgi || __ppc__ || __arm__
|
|
typedef unsigned char UChar;
|
|
typedef short Int16;
|
|
typedef unsigned short UInt16;
|
|
@@ -164,7 +164,7 @@
|
|
|
|
/* x86-64 */
|
|
/* Note that these may be appropriate for other 64-bit machines. */
|
|
-#elif __x86_64__ || __ia64__
|
|
+#elif __x86_64__ || __ia64__ || __aarch64__
|
|
typedef unsigned char UChar;
|
|
typedef short Int16;
|
|
typedef unsigned short UInt16;
|