mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-12-08 23:03:46 +00:00
98 lines
3.3 KiB
Diff
98 lines
3.3 KiB
Diff
--- src/libffwma/avcodec.h.orig 2005-10-07 11:49:36.000000000 -0400
|
|
+++ src/libffwma/avcodec.h 2005-10-07 11:51:09.000000000 -0400
|
|
@@ -11,6 +11,43 @@
|
|
extern "C" {
|
|
#endif
|
|
|
|
+
|
|
+/**
|
|
+ * AVOption.
|
|
+ */
|
|
+typedef struct AVOption {
|
|
+ /** options' name */
|
|
+ const char *name; /* if name is NULL, it indicates a link to next */
|
|
+ /** short English text help or const struct AVOption* subpointer */
|
|
+ const char *help; // const struct AVOption* sub;
|
|
+ /** offset to context structure where the parsed value should be stored */
|
|
+ int offset;
|
|
+ /** options' type */
|
|
+ int type;
|
|
+#define FF_OPT_TYPE_BOOL 1 ///< boolean - true,1,on (or simply presence)
|
|
+#define FF_OPT_TYPE_DOUBLE 2 ///< double
|
|
+#define FF_OPT_TYPE_INT 3 ///< integer
|
|
+#define FF_OPT_TYPE_STRING 4 ///< string (finished with \0)
|
|
+#define FF_OPT_TYPE_MASK 0x1f ///< mask for types - upper bits are various flags
|
|
+//#define FF_OPT_TYPE_EXPERT 0x20 // flag for expert option
|
|
+#define FF_OPT_TYPE_FLAG (FF_OPT_TYPE_BOOL | 0x40)
|
|
+#define FF_OPT_TYPE_RCOVERRIDE (FF_OPT_TYPE_STRING | 0x80)
|
|
+ /** min value (min == max -> no limits) */
|
|
+ double min;
|
|
+ /** maximum value for double/int */
|
|
+ double max;
|
|
+ /** default boo [0,1]l/double/int value */
|
|
+ double defval;
|
|
+ /**
|
|
+ * default string value (with optional semicolon delimited extra option-list
|
|
+ * i.e. option1;option2;option3
|
|
+ * defval might select other then first argument as default
|
|
+ */
|
|
+ const char *defstr;
|
|
+#define FF_OPT_MAX_DEPTH 10
|
|
+} AVOption;
|
|
+
|
|
+
|
|
#include "common.h"
|
|
#include <sys/types.h> /* size_t */
|
|
|
|
@@ -1396,41 +1433,6 @@
|
|
|
|
|
|
/**
|
|
- * AVOption.
|
|
- */
|
|
-typedef struct AVOption {
|
|
- /** options' name */
|
|
- const char *name; /* if name is NULL, it indicates a link to next */
|
|
- /** short English text help or const struct AVOption* subpointer */
|
|
- const char *help; // const struct AVOption* sub;
|
|
- /** offset to context structure where the parsed value should be stored */
|
|
- int offset;
|
|
- /** options' type */
|
|
- int type;
|
|
-#define FF_OPT_TYPE_BOOL 1 ///< boolean - true,1,on (or simply presence)
|
|
-#define FF_OPT_TYPE_DOUBLE 2 ///< double
|
|
-#define FF_OPT_TYPE_INT 3 ///< integer
|
|
-#define FF_OPT_TYPE_STRING 4 ///< string (finished with \0)
|
|
-#define FF_OPT_TYPE_MASK 0x1f ///< mask for types - upper bits are various flags
|
|
-//#define FF_OPT_TYPE_EXPERT 0x20 // flag for expert option
|
|
-#define FF_OPT_TYPE_FLAG (FF_OPT_TYPE_BOOL | 0x40)
|
|
-#define FF_OPT_TYPE_RCOVERRIDE (FF_OPT_TYPE_STRING | 0x80)
|
|
- /** min value (min == max -> no limits) */
|
|
- double min;
|
|
- /** maximum value for double/int */
|
|
- double max;
|
|
- /** default boo [0,1]l/double/int value */
|
|
- double defval;
|
|
- /**
|
|
- * default string value (with optional semicolon delimited extra option-list
|
|
- * i.e. option1;option2;option3
|
|
- * defval might select other then first argument as default
|
|
- */
|
|
- const char *defstr;
|
|
-#define FF_OPT_MAX_DEPTH 10
|
|
-} AVOption;
|
|
-
|
|
-/**
|
|
* Parse option(s) and sets fields in passed structure
|
|
* @param strct structure where the parsed results will be written
|
|
* @param list list with AVOptions
|
|
--- src/libffwma/dsputil.h.orig 2005-10-07 11:51:59.000000000 -0400
|
|
+++ src/libffwma/dsputil.h 2005-10-07 11:52:17.000000000 -0400
|
|
@@ -28,7 +28,6 @@
|
|
#ifndef DSPUTIL_H
|
|
#define DSPUTIL_H
|
|
|
|
-#include "common.h"
|
|
#include "avcodec.h"
|
|
|
|
|