mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
28 lines
652 B
Diff
28 lines
652 B
Diff
--- src/search.c.orig 2008-11-07 00:38:18.000000000 +0100
|
|
+++ src/search.c 2008-11-07 00:50:51.000000000 +0100
|
|
@@ -83,6 +83,8 @@
|
|
dlclose(pcFilename);
|
|
free(pcFilename);
|
|
}
|
|
+ } else {
|
|
+ free(pcFilename);
|
|
}
|
|
}
|
|
}
|
|
@@ -99,13 +101,10 @@
|
|
|
|
pcLADSPAPath = getenv("LADSPA_PATH");
|
|
if (!pcLADSPAPath) {
|
|
- fprintf(stderr,
|
|
- "Warning: You do not have a LADSPA_PATH "
|
|
- "environment variable set.\n");
|
|
- return;
|
|
+ pcStart = "/usr/lib/ladspa/";
|
|
+ } else {
|
|
+ pcStart = pcLADSPAPath;
|
|
}
|
|
-
|
|
- pcStart = pcLADSPAPath;
|
|
while (*pcStart != '\0') {
|
|
pcEnd = pcStart;
|
|
while (*pcEnd != ':' && *pcEnd != '\0')
|