mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
38 lines
1.5 KiB
Diff
38 lines
1.5 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Alexandros Frantzis <alexandros.frantzis@collabora.com>
|
|
Date: Thu, 2 Mar 2023 09:35:08 +0200
|
|
Subject: [PATCH] egl/wayland: Fix destruction of event queue with proxies
|
|
still attached.
|
|
|
|
Destroy the display wrapper proxy before destroying the event queue that
|
|
the proxy is attached to.
|
|
|
|
This silences a warning that libwayland 1.22 emits for programs that use
|
|
EGL/Wayland:
|
|
|
|
warning: queue 0x562a5ed2cd20 destroyed while proxies still attached:
|
|
wl_display@1 still attached
|
|
|
|
Signed-off-by: Alexandros Frantzis <alexandros.frantzis@collabora.com>
|
|
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/21646>
|
|
---
|
|
src/egl/drivers/dri2/platform_wayland.c | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/src/egl/drivers/dri2/platform_wayland.c b/src/egl/drivers/dri2/platform_wayland.c
|
|
index 32b0ff70002d..962bc34a2166 100644
|
|
--- a/src/egl/drivers/dri2/platform_wayland.c
|
|
+++ b/src/egl/drivers/dri2/platform_wayland.c
|
|
@@ -2800,10 +2800,10 @@ dri2_teardown_wayland(struct dri2_egl_display *dri2_dpy)
|
|
wl_shm_destroy(dri2_dpy->wl_shm);
|
|
if (dri2_dpy->wl_registry)
|
|
wl_registry_destroy(dri2_dpy->wl_registry);
|
|
- if (dri2_dpy->wl_queue)
|
|
- wl_event_queue_destroy(dri2_dpy->wl_queue);
|
|
if (dri2_dpy->wl_dpy_wrapper)
|
|
wl_proxy_wrapper_destroy(dri2_dpy->wl_dpy_wrapper);
|
|
+ if (dri2_dpy->wl_queue)
|
|
+ wl_event_queue_destroy(dri2_dpy->wl_queue);
|
|
|
|
if (dri2_dpy->own_device)
|
|
wl_display_disconnect(dri2_dpy->wl_dpy);
|