mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
32 lines
1.2 KiB
Diff
32 lines
1.2 KiB
Diff
# HG changeset patch
|
|
# User andrew
|
|
# Date 1518667645 0
|
|
# Thu Feb 15 04:07:25 2018 +0000
|
|
# Node ID 1d35411eb7bdf16191e220ffe3b1dc4d5d0c6041
|
|
# Parent 999983606f5c61b093c6f6316a7b26c4cd4ca79e
|
|
8197981, PR3548: Missing return statement in __sync_val_compare_and_swap_8
|
|
Summary: Fix issue discovered by -Wreturn-type on systems without LP64.
|
|
Reviewed-by: aph
|
|
|
|
diff --git openjdk.orig/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp openjdk/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp
|
|
--- openjdk.orig/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp
|
|
+++ openjdk/hotspot/src/os_cpu/bsd_zero/vm/os_bsd_zero.cpp
|
|
@@ -457,6 +457,7 @@
|
|
long long unsigned int oldval,
|
|
long long unsigned int newval) {
|
|
ShouldNotCallThis();
|
|
+ return 0;
|
|
}
|
|
};
|
|
#endif // !_LP64
|
|
diff --git openjdk.orig/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp openjdk/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
|
--- openjdk.orig/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
|
+++ openjdk/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
|
@@ -498,6 +498,7 @@
|
|
long long unsigned int oldval,
|
|
long long unsigned int newval) {
|
|
ShouldNotCallThis();
|
|
+ return 0;
|
|
}
|
|
};
|
|
#endif // !_LP64
|