mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-27 00:10:29 +00:00
26 lines
1,014 B
Diff
26 lines
1,014 B
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Morgan Rae Reschenberg <mreschenberg@mozilla.com>
|
|
Date: Wed, 24 Aug 2022 04:44:38 +0000
|
|
Subject: [PATCH] Bug 1786638: Return early if we can't fetch an internal obj
|
|
when computing ATK relations r=Jamie
|
|
|
|
Differential Revision: https://phabricator.services.mozilla.com/D155426
|
|
---
|
|
accessible/atk/AccessibleWrap.cpp | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/accessible/atk/AccessibleWrap.cpp b/accessible/atk/AccessibleWrap.cpp
|
|
index 85281ba2cc20..2bdb40ddcb15 100644
|
|
--- a/accessible/atk/AccessibleWrap.cpp
|
|
+++ b/accessible/atk/AccessibleWrap.cpp
|
|
@@ -836,6 +836,10 @@ AtkRelationSet* refRelationSetCB(AtkObject* aAtkObj) {
|
|
ATK_OBJECT_CLASS(parent_class)->ref_relation_set(aAtkObj);
|
|
|
|
Accessible* acc = GetInternalObj(aAtkObj);
|
|
+ if (!acc) {
|
|
+ return relation_set;
|
|
+ }
|
|
+
|
|
if (!StaticPrefs::accessibility_cache_enabled_AtStartup() &&
|
|
acc->IsRemote()) {
|
|
RemoteAccessible* proxy = acc->AsRemote();
|