mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
48 lines
1.5 KiB
Diff
48 lines
1.5 KiB
Diff
From 16409cad4cb4ccd7c914da4317740550cc00200c Mon Sep 17 00:00:00 2001
|
|
From: Nigel Croxon <nigel.croxon@hpe.com>
|
|
Date: Wed, 23 Dec 2015 08:38:24 -0500
|
|
Subject: [PATCH 07/10] From: Ard Biesheuvel <ard.biesheuvel@linaro.org>
|
|
Subject: [PATCH] Add ARM .note.gnu.build-id input section to a dedicated
|
|
output section
|
|
|
|
This fixes the builds for ARM and AARCH64, which currently fail at link
|
|
time with an error like this:
|
|
|
|
arm-linux-gnueabi-ld: section .note.gnu.build-id loaded at
|
|
[0000000000000000,0000000000000023] overlaps section .text loaded at
|
|
[0000000000000000,00000000000064cf]
|
|
|
|
Signed-off-by: Ard Biesheuvel <ard.biesheuvel@linaro.org>
|
|
Signed-off-by: Nigel Croxon <nigel.croxon@hpe.com>
|
|
---
|
|
gnuefi/elf_aarch64_efi.lds | 1 +
|
|
gnuefi/elf_arm_efi.lds | 1 +
|
|
2 files changed, 2 insertions(+)
|
|
|
|
diff --git a/gnuefi/elf_aarch64_efi.lds b/gnuefi/elf_aarch64_efi.lds
|
|
index 6494e59..8864757 100644
|
|
--- a/gnuefi/elf_aarch64_efi.lds
|
|
+++ b/gnuefi/elf_aarch64_efi.lds
|
|
@@ -50,6 +50,7 @@ SECTIONS
|
|
. = ALIGN(4096);
|
|
.dynstr : { *(.dynstr) }
|
|
. = ALIGN(4096);
|
|
+ .note.gnu.build-id : { *(.note.gnu.build-id) }
|
|
/DISCARD/ :
|
|
{
|
|
*(.rel.reloc)
|
|
diff --git a/gnuefi/elf_arm_efi.lds b/gnuefi/elf_arm_efi.lds
|
|
index 63d31be..a2f1b01 100644
|
|
--- a/gnuefi/elf_arm_efi.lds
|
|
+++ b/gnuefi/elf_arm_efi.lds
|
|
@@ -50,6 +50,7 @@ SECTIONS
|
|
. = ALIGN(4096);
|
|
.dynstr : { *(.dynstr) }
|
|
. = ALIGN(4096);
|
|
+ .note.gnu.build-id : { *(.note.gnu.build-id) }
|
|
/DISCARD/ :
|
|
{
|
|
*(.rel.reloc)
|
|
--
|
|
2.5.0
|
|
|