mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
11 lines
381 B
Diff
11 lines
381 B
Diff
--- src/lbaselib.c (old)
|
|
+++ src/lbaselib.c (new)
|
|
@@ -526,7 +526,7 @@
|
|
status = lua_resume(co, narg);
|
|
if (status == 0 || status == LUA_YIELD) {
|
|
int nres = lua_gettop(co);
|
|
- if (!lua_checkstack(L, nres))
|
|
+ if (!lua_checkstack(L, nres + 1))
|
|
luaL_error(L, "too many results to resume");
|
|
lua_xmove(co, L, nres); /* move yielded values */
|
|
return nres;
|