PKGBUILDs/core/gcc/gcc-4.7.1-libgo-write.patch
2013-02-20 12:23:40 -06:00

13 lines
420 B
Diff

diff -Naur gcc-4.7.1-orig/libgo/runtime/print.c gcc-4.7.1/libgo/runtime/print.c
--- gcc-4.7.1-orig/libgo/runtime/print.c 2012-05-26 04:22:14.000000000 +1000
+++ gcc-4.7.1/libgo/runtime/print.c 2012-06-16 15:06:28.553138502 +1000
@@ -17,7 +17,8 @@
G* g = runtime_g();
if(g == nil || g->writebuf == nil) {
- runtime_write(2, v, n);
+ ssize_t bytesWritten = runtime_write(2, v, n);
+ (void)bytesWritten;
return;
}