mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
466 lines
12 KiB
Diff
466 lines
12 KiB
Diff
diff -urN a/arch/arm/mach-kirkwood/dockstar-setup.c b/arch/arm/mach-kirkwood/dockstar-setup.c
|
|
--- a/arch/arm/mach-kirkwood/dockstar-setup.c 2011-05-18 22:06:34.000000000 -0600
|
|
+++ b/arch/arm/mach-kirkwood/dockstar-setup.c 2011-07-01 13:18:36.000000000 -0600
|
|
@@ -19,7 +19,6 @@
|
|
#include <asm/mach-types.h>
|
|
#include <asm/mach/arch.h>
|
|
#include <mach/kirkwood.h>
|
|
-#include <plat/mvsdio.h>
|
|
#include "common.h"
|
|
#include "mpp.h"
|
|
|
|
@@ -33,6 +32,10 @@
|
|
.offset = MTDPART_OFS_NXTBLK,
|
|
.size = SZ_4M
|
|
}, {
|
|
+ .name = "pogoplug",
|
|
+ .offset = MTDPART_OFS_NXTBLK,
|
|
+ .size = SZ_32M
|
|
+ }, {
|
|
.name = "root",
|
|
.offset = MTDPART_OFS_NXTBLK,
|
|
.size = MTDPART_SIZ_FULL
|
|
@@ -45,17 +48,17 @@
|
|
|
|
static struct gpio_led dockstar_led_pins[] = {
|
|
{
|
|
- .name = "dockstar:green:health",
|
|
+ .name = "status:green:health",
|
|
.default_trigger = "default-on",
|
|
.gpio = 46,
|
|
.active_low = 1,
|
|
},
|
|
{
|
|
- .name = "dockstar:orange:misc",
|
|
+ .name = "status:orange:fault",
|
|
.default_trigger = "none",
|
|
.gpio = 47,
|
|
.active_low = 1,
|
|
- },
|
|
+ }
|
|
};
|
|
|
|
static struct gpio_led_platform_data dockstar_led_data = {
|
|
@@ -73,8 +76,8 @@
|
|
|
|
static unsigned int dockstar_mpp_config[] __initdata = {
|
|
MPP29_GPIO, /* USB Power Enable */
|
|
- MPP46_GPIO, /* LED green */
|
|
- MPP47_GPIO, /* LED orange */
|
|
+ MPP47_GPIO, /* LED Orange */
|
|
+ MPP46_GPIO, /* LED Green */
|
|
0
|
|
};
|
|
|
|
diff -urN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/goflexhome-setup.c
|
|
--- a/arch/arm/mach-kirkwood/goflexhome-setup.c 1969-12-31 17:00:00.000000000 -0700
|
|
+++ b/arch/arm/mach-kirkwood/goflexhome-setup.c 2011-07-01 13:25:34.000000000 -0600
|
|
@@ -0,0 +1,123 @@
|
|
+/*
|
|
+ * arch/arm/mach-kirkwood/goflexhome-setup.c
|
|
+ *
|
|
+ * Seagate GoFlex Home Setup
|
|
+ *
|
|
+ * This file is licensed under the terms of the GNU General Public
|
|
+ * License version 2. This program is licensed "as is" without any
|
|
+ * warranty of any kind, whether express or implied.
|
|
+ */
|
|
+
|
|
+#include <linux/kernel.h>
|
|
+#include <linux/init.h>
|
|
+#include <linux/platform_device.h>
|
|
+#include <linux/ata_platform.h>
|
|
+#include <linux/mtd/partitions.h>
|
|
+#include <linux/mv643xx_eth.h>
|
|
+#include <linux/gpio.h>
|
|
+#include <linux/leds.h>
|
|
+#include <asm/mach-types.h>
|
|
+#include <asm/mach/arch.h>
|
|
+#include <mach/kirkwood.h>
|
|
+#include "common.h"
|
|
+#include "mpp.h"
|
|
+
|
|
+static struct mtd_partition goflexhome_nand_parts[] = {
|
|
+ {
|
|
+ .name = "u-boot",
|
|
+ .offset = 0,
|
|
+ .size = SZ_1M
|
|
+ }, {
|
|
+ .name = "uImage",
|
|
+ .offset = MTDPART_OFS_NXTBLK,
|
|
+ .size = SZ_2M + SZ_4M
|
|
+ }, {
|
|
+ .name = "root",
|
|
+ .offset = MTDPART_OFS_NXTBLK,
|
|
+ .size = MTDPART_SIZ_FULL
|
|
+ },
|
|
+};
|
|
+
|
|
+static struct mv643xx_eth_platform_data goflexhome_ge00_data = {
|
|
+ .phy_addr = MV643XX_ETH_PHY_ADDR(0),
|
|
+};
|
|
+
|
|
+static struct mv_sata_platform_data goflexhome_sata_data = {
|
|
+ .n_ports = 1,
|
|
+};
|
|
+
|
|
+static struct gpio_led goflexhome_led_pins[] = {
|
|
+ {
|
|
+ .name = "status:green:health",
|
|
+ .default_trigger = "default-on",
|
|
+ .gpio = 46,
|
|
+ .active_low = 1,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:orange:fault",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 47,
|
|
+ .active_low = 1,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:white:misc",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 40,
|
|
+ .active_low = 0,
|
|
+ }
|
|
+};
|
|
+
|
|
+static struct gpio_led_platform_data goflexhome_led_data = {
|
|
+ .leds = goflexhome_led_pins,
|
|
+ .num_leds = ARRAY_SIZE(goflexhome_led_pins),
|
|
+};
|
|
+
|
|
+static struct platform_device goflexhome_leds = {
|
|
+ .name = "leds-gpio",
|
|
+ .id = -1,
|
|
+ .dev = {
|
|
+ .platform_data = &goflexhome_led_data,
|
|
+ }
|
|
+};
|
|
+
|
|
+static unsigned int goflexhome_mpp_config[] __initdata = {
|
|
+ MPP29_GPIO, /* USB Power Enable */
|
|
+ MPP47_GPIO, /* LED Orange */
|
|
+ MPP46_GPIO, /* LED Green */
|
|
+ MPP40_GPIO, /* LED White */
|
|
+ 0
|
|
+};
|
|
+
|
|
+static void __init goflexhome_init(void)
|
|
+{
|
|
+ /*
|
|
+ * Basic setup. Needs to be called early.
|
|
+ */
|
|
+ kirkwood_init();
|
|
+
|
|
+ /* setup gpio pin select */
|
|
+ kirkwood_mpp_conf(goflexhome_mpp_config);
|
|
+
|
|
+ kirkwood_uart0_init();
|
|
+ kirkwood_nand_init(ARRAY_AND_SIZE(goflexhome_nand_parts), 25);
|
|
+
|
|
+ if (gpio_request(29, "USB Power Enable") != 0 ||
|
|
+ gpio_direction_output(29, 1) != 0)
|
|
+ printk(KERN_ERR "can't set up GPIO 29 (USB Power Enable)\n");
|
|
+ kirkwood_ehci_init();
|
|
+ kirkwood_ge00_init(&goflexhome_ge00_data);
|
|
+ kirkwood_sata_init(&goflexhome_sata_data);
|
|
+
|
|
+ platform_device_register(&goflexhome_leds);
|
|
+}
|
|
+
|
|
+MACHINE_START(GOFLEXHOME, "Seagate GoFlex Home")
|
|
+ /* Maintainer: Peter Carmichael <peterjncarm@ovi.com> */
|
|
+ .boot_params = 0x00000100,
|
|
+ .init_machine = goflexhome_init,
|
|
+ .map_io = kirkwood_map_io,
|
|
+ .init_early = kirkwood_init_early,
|
|
+ .init_irq = kirkwood_init_irq,
|
|
+ .timer = &kirkwood_timer,
|
|
+MACHINE_END
|
|
+
|
|
diff -urN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/goflexnet-setup.c
|
|
--- a/arch/arm/mach-kirkwood/goflexnet-setup.c 1969-12-31 17:00:00.000000000 -0700
|
|
+++ b/arch/arm/mach-kirkwood/goflexnet-setup.c 2011-07-01 13:25:49.000000000 -0600
|
|
@@ -0,0 +1,176 @@
|
|
+/*
|
|
+ * arch/arm/mach-kirkwood/goflexnet-setup.c
|
|
+ *
|
|
+ * Seagate GoFlex Net Setup
|
|
+ *
|
|
+ * This file is licensed under the terms of the GNU General Public
|
|
+ * License version 2. This program is licensed "as is" without any
|
|
+ * warranty of any kind, whether express or implied.
|
|
+ */
|
|
+
|
|
+#include <linux/kernel.h>
|
|
+#include <linux/init.h>
|
|
+#include <linux/platform_device.h>
|
|
+#include <linux/ata_platform.h>
|
|
+#include <linux/mtd/partitions.h>
|
|
+#include <linux/mv643xx_eth.h>
|
|
+#include <linux/gpio.h>
|
|
+#include <linux/leds.h>
|
|
+#include <asm/mach-types.h>
|
|
+#include <asm/mach/arch.h>
|
|
+#include <mach/kirkwood.h>
|
|
+#include "common.h"
|
|
+#include "mpp.h"
|
|
+
|
|
+static struct mtd_partition goflexnet_nand_parts[] = {
|
|
+ {
|
|
+ .name = "u-boot",
|
|
+ .offset = 0,
|
|
+ .size = SZ_1M
|
|
+ }, {
|
|
+ .name = "uImage",
|
|
+ .offset = MTDPART_OFS_NXTBLK,
|
|
+ .size = SZ_4M
|
|
+ }, {
|
|
+ .name = "pogoplug",
|
|
+ .offset = MTDPART_OFS_NXTBLK,
|
|
+ .size = SZ_32M
|
|
+ }, {
|
|
+ .name = "root",
|
|
+ .offset = MTDPART_OFS_NXTBLK,
|
|
+ .size = MTDPART_SIZ_FULL
|
|
+ },
|
|
+};
|
|
+
|
|
+static struct mv643xx_eth_platform_data goflexnet_ge00_data = {
|
|
+ .phy_addr = MV643XX_ETH_PHY_ADDR(0),
|
|
+};
|
|
+
|
|
+static struct mv_sata_platform_data goflexnet_sata_data = {
|
|
+ .n_ports = 2,
|
|
+};
|
|
+
|
|
+static struct gpio_led goflexnet_led_pins[] = {
|
|
+ {
|
|
+ .name = "status:green:health",
|
|
+ .default_trigger = "default-on",
|
|
+ .gpio = 46, // 0x4000
|
|
+ .active_low = 1,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:orange:fault",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 47, // 0x8000
|
|
+ .active_low = 1,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:white:left0",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 42, // 0x0400
|
|
+ .active_low = 0,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:white:left1",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 43, // 0x0800
|
|
+ .active_low = 0,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:white:left2",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 44, // 0x1000
|
|
+ .active_low = 0,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:white:left3",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 45, // 0x2000
|
|
+ .active_low = 0,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:white:right0",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 38, // 0x0040
|
|
+ .active_low = 0,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:white:right1",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 39, // 0x0080
|
|
+ .active_low = 0,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:white:right2",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 40, // 0x0100
|
|
+ .active_low = 0,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:white:right3",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 41, // 0x0200
|
|
+ .active_low = 0,
|
|
+ }
|
|
+};
|
|
+
|
|
+static struct gpio_led_platform_data goflexnet_led_data = {
|
|
+ .leds = goflexnet_led_pins,
|
|
+ .num_leds = ARRAY_SIZE(goflexnet_led_pins),
|
|
+};
|
|
+
|
|
+static struct platform_device goflexnet_leds = {
|
|
+ .name = "leds-gpio",
|
|
+ .id = -1,
|
|
+ .dev = {
|
|
+ .platform_data = &goflexnet_led_data,
|
|
+ }
|
|
+};
|
|
+
|
|
+static unsigned int goflexnet_mpp_config[] __initdata = {
|
|
+ MPP29_GPIO, /* USB Power Enable */
|
|
+ MPP47_GPIO, /* LED Orange */
|
|
+ MPP46_GPIO, /* LED Green */
|
|
+ MPP45_GPIO, /* LED Left Capacity 3 */
|
|
+ MPP44_GPIO, /* LED Left Capacity 2 */
|
|
+ MPP43_GPIO, /* LED Left Capacity 1 */
|
|
+ MPP42_GPIO, /* LED Left Capacity 0 */
|
|
+ MPP41_GPIO, /* LED Right Capacity 3 */
|
|
+ MPP40_GPIO, /* LED Right Capacity 2 */
|
|
+ MPP39_GPIO, /* LED Right Capacity 1 */
|
|
+ MPP38_GPIO, /* LED Right Capacity 0 */
|
|
+ 0
|
|
+};
|
|
+
|
|
+static void __init goflexnet_init(void)
|
|
+{
|
|
+ /*
|
|
+ * Basic setup. Needs to be called early.
|
|
+ */
|
|
+ kirkwood_init();
|
|
+
|
|
+ /* setup gpio pin select */
|
|
+ kirkwood_mpp_conf(goflexnet_mpp_config);
|
|
+
|
|
+ kirkwood_uart0_init();
|
|
+ kirkwood_nand_init(ARRAY_AND_SIZE(goflexnet_nand_parts), 25);
|
|
+
|
|
+ if (gpio_request(29, "USB Power Enable") != 0 ||
|
|
+ gpio_direction_output(29, 1) != 0)
|
|
+ printk(KERN_ERR "can't set up GPIO 29 (USB Power Enable)\n");
|
|
+ kirkwood_ehci_init();
|
|
+ kirkwood_ge00_init(&goflexnet_ge00_data);
|
|
+ kirkwood_sata_init(&goflexnet_sata_data);
|
|
+
|
|
+ platform_device_register(&goflexnet_leds);
|
|
+}
|
|
+
|
|
+MACHINE_START(GOFLEXNET, "Seagate GoFlex Net")
|
|
+ /* Maintainer: Peter Carmichael <peterjncarm@ovi.com> */
|
|
+ .boot_params = 0x00000100,
|
|
+ .init_machine = goflexnet_init,
|
|
+ .map_io = kirkwood_map_io,
|
|
+ .init_early = kirkwood_init_early,
|
|
+ .init_irq = kirkwood_init_irq,
|
|
+ .timer = &kirkwood_timer,
|
|
+MACHINE_END
|
|
+
|
|
diff -urN a/arch/arm/mach-kirkwood/guruplug-setup.c b/arch/arm/mach-kirkwood/guruplug-setup.c
|
|
--- a/arch/arm/mach-kirkwood/guruplug-setup.c 2011-05-18 22:06:34.000000000 -0600
|
|
+++ b/arch/arm/mach-kirkwood/guruplug-setup.c 2011-07-01 13:18:36.000000000 -0600
|
|
@@ -57,22 +57,24 @@
|
|
|
|
static struct gpio_led guruplug_led_pins[] = {
|
|
{
|
|
- .name = "guruplug:red:health",
|
|
+ .name = "status:red:fault",
|
|
+ .default_trigger = "none",
|
|
.gpio = 46,
|
|
.active_low = 1,
|
|
},
|
|
{
|
|
- .name = "guruplug:green:health",
|
|
+ .name = "status:green:health",
|
|
+ .default_trigger = "default-on",
|
|
.gpio = 47,
|
|
.active_low = 1,
|
|
},
|
|
{
|
|
- .name = "guruplug:red:wmode",
|
|
+ .name = "status:red:wmode",
|
|
.gpio = 48,
|
|
.active_low = 1,
|
|
},
|
|
{
|
|
- .name = "guruplug:green:wmode",
|
|
+ .name = "status:green:wmode",
|
|
.gpio = 49,
|
|
.active_low = 1,
|
|
},
|
|
diff -urN a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
|
|
--- a/arch/arm/mach-kirkwood/Kconfig 2011-05-18 22:06:34.000000000 -0600
|
|
+++ b/arch/arm/mach-kirkwood/Kconfig 2011-07-01 13:18:36.000000000 -0600
|
|
@@ -64,6 +64,18 @@
|
|
Say 'Y' here if you want your kernel to support the
|
|
Seagate FreeAgent DockStar.
|
|
|
|
+config MACH_GOFLEXNET
|
|
+ bool "Seagate GoFlex Net"
|
|
+ help
|
|
+ Say 'Y' here if you want your kernel to support the
|
|
+ Seagate GoFlex Net.
|
|
+
|
|
+config MACH_GOFLEXHOME
|
|
+ bool "Seagate GoFlex Home"
|
|
+ help
|
|
+ Say 'Y' here if you want your kernel to support the
|
|
+ Seagate GoFlex Home.
|
|
+
|
|
config MACH_OPENRD
|
|
bool
|
|
|
|
diff -urN a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
|
|
--- a/arch/arm/mach-kirkwood/Makefile 2011-05-18 22:06:34.000000000 -0600
|
|
+++ b/arch/arm/mach-kirkwood/Makefile 2011-07-01 13:18:36.000000000 -0600
|
|
@@ -8,6 +8,8 @@
|
|
obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG) += sheevaplug-setup.o
|
|
obj-$(CONFIG_MACH_GURUPLUG) += guruplug-setup.o
|
|
obj-$(CONFIG_MACH_DOCKSTAR) += dockstar-setup.o
|
|
+obj-$(CONFIG_MACH_GOFLEXNET) += goflexnet-setup.o
|
|
+obj-$(CONFIG_MACH_GOFLEXHOME) += goflexhome-setup.o
|
|
obj-$(CONFIG_MACH_TS219) += ts219-setup.o tsx1x-common.o
|
|
obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o tsx1x-common.o
|
|
obj-$(CONFIG_MACH_OPENRD) += openrd-setup.o
|
|
diff -urN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/sheevaplug-setup.c
|
|
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c 2011-05-18 22:06:34.000000000 -0600
|
|
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c 2011-07-01 13:22:51.000000000 -0600
|
|
@@ -64,7 +64,13 @@
|
|
.active_low = 1,
|
|
},
|
|
{
|
|
- .name = "plug:green:health",
|
|
+ .name = "status:green:health",
|
|
+ .default_trigger = "none",
|
|
+ .gpio = 48,
|
|
+ .active_low = 1,
|
|
+ },
|
|
+ {
|
|
+ .name = "status:blue:health",
|
|
.default_trigger = "default-on",
|
|
.gpio = 49,
|
|
.active_low = 1,
|
|
@@ -87,7 +93,8 @@
|
|
static unsigned int sheevaplug_mpp_config[] __initdata = {
|
|
MPP29_GPIO, /* USB Power Enable */
|
|
MPP46_GPIO, /* LED Red */
|
|
- MPP49_GPIO, /* LED */
|
|
+ MPP48_GPIO, /* LED Green */
|
|
+ MPP49_GPIO, /* LED Blue */
|
|
0
|
|
};
|
|
|
|
@@ -95,7 +102,9 @@
|
|
MPP29_GPIO, /* USB Power Enable */
|
|
MPP44_GPIO, /* SD Write Protect */
|
|
MPP47_GPIO, /* SD Card Detect */
|
|
- MPP49_GPIO, /* LED Green */
|
|
+ MPP46_GPIO, /* LED Red */
|
|
+ MPP48_GPIO, /* LED Green */
|
|
+ MPP49_GPIO, /* LED Blue */
|
|
0
|
|
};
|
|
|