mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
17 lines
579 B
Diff
17 lines
579 B
Diff
From c0c403744b1bf4a9790a8fcaabcd60970cbefe06 Mon Sep 17 00:00:00 2001
|
|
From: Michael R Sweet <michael.r.sweet@gmail.com>
|
|
Date: Tue, 7 Jun 2022 13:45:29 -0400
|
|
Subject: [PATCH] Fix OpenSSL crash bug - "tls" pointer wasn't cleared after
|
|
freeing it (Issue #409)
|
|
|
|
diff --git a/cups/tls-openssl.c b/cups/tls-openssl.c
|
|
index c3e57742e..6db9f8a9c 100644
|
|
--- a/cups/tls-openssl.c
|
|
+++ b/cups/tls-openssl.c
|
|
@@ -1152,6 +1152,8 @@ _httpTLSStop(http_t *http) // I - Connection to server
|
|
SSL_shutdown(http->tls);
|
|
SSL_CTX_free(context);
|
|
SSL_free(http->tls);
|
|
+
|
|
+ http->tls = NULL;
|
|
}
|