mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
11 lines
502 B
Diff
11 lines
502 B
Diff
--- CMakeLists.txt.orig 2018-09-11 07:50:54.763206560 -0600
|
|
+++ CMakeLists.txt 2018-09-11 07:51:56.040874745 -0600
|
|
@@ -945,7 +945,7 @@
|
|
# Check for ARM Neon support
|
|
OPTION(ALSOFT_REQUIRE_NEON "Require ARM Neon support" OFF)
|
|
CHECK_INCLUDE_FILE(arm_neon.h HAVE_ARM_NEON_H ${FPU_NEON_SWITCH})
|
|
-IF(HAVE_ARM_NEON_H)
|
|
+IF(HAVE_ARM_NEON_H AND CMAKE_SIZEOF_VOID_P EQUAL 4) # only 32-bit ARM
|
|
OPTION(ALSOFT_CPUEXT_NEON "Enable ARM Neon support" ON)
|
|
IF(ALSOFT_CPUEXT_NEON)
|
|
SET(HAVE_NEON 1)
|