mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
36 lines
1.6 KiB
Diff
36 lines
1.6 KiB
Diff
From 8505374ee208d51a39e7b22846f9b781b9ccb452 Mon Sep 17 00:00:00 2001
|
|
Message-Id: <8505374ee208d51a39e7b22846f9b781b9ccb452.1515434692.git.mschiffer@universe-factory.net>
|
|
From: Matthias Schiffer <mschiffer@universe-factory.net>
|
|
Date: Fri, 19 May 2017 19:36:24 +0200
|
|
Subject: [PATCH] cipher: aes128-ctr: openssl: fix compatiblity with OpenSSL
|
|
1.1
|
|
|
|
---
|
|
src/crypto/cipher/aes128_ctr/openssl/aes128_ctr_openssl.c | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/src/crypto/cipher/aes128_ctr/openssl/aes128_ctr_openssl.c b/src/crypto/cipher/aes128_ctr/openssl/aes128_ctr_openssl.c
|
|
index 7a2b565..c44427f 100644
|
|
--- a/src/crypto/cipher/aes128_ctr/openssl/aes128_ctr_openssl.c
|
|
+++ b/src/crypto/cipher/aes128_ctr/openssl/aes128_ctr_openssl.c
|
|
@@ -47,7 +47,7 @@ static fastd_cipher_state_t * aes128_ctr_init(const uint8_t *key) {
|
|
fastd_cipher_state_t *state = fastd_new(fastd_cipher_state_t);
|
|
|
|
state->aes = EVP_CIPHER_CTX_new();
|
|
- EVP_EncryptInit(state->aes, EVP_aes_128_ctr(), (const unsigned char *)key, NULL);
|
|
+ EVP_EncryptInit_ex(state->aes, EVP_aes_128_ctr(), NULL, (const unsigned char *)key, NULL);
|
|
|
|
return state;
|
|
}
|
|
@@ -56,7 +56,7 @@ static fastd_cipher_state_t * aes128_ctr_init(const uint8_t *key) {
|
|
static bool aes128_ctr_crypt(const fastd_cipher_state_t *state, fastd_block128_t *out, const fastd_block128_t *in, size_t len, const uint8_t *iv) {
|
|
int clen, clen2;
|
|
|
|
- if (!EVP_EncryptInit(state->aes, NULL, NULL, iv))
|
|
+ if (!EVP_EncryptInit_ex(state->aes, NULL, NULL, NULL, iv))
|
|
return false;
|
|
|
|
if (!EVP_EncryptUpdate(state->aes, (unsigned char *)out, &clen, (const unsigned char *)in, len))
|
|
--
|
|
2.15.1
|
|
|