mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
27 lines
593 B
Diff
27 lines
593 B
Diff
--- gimp-2.2.11/plug-ins/common/png.c.orig 2007-03-12 00:30:20.000000000 -0400
|
|
+++ gimp-2.2.11/plug-ins/common/png.c 2007-03-12 00:34:33.000000000 -0400
|
|
@@ -1012,7 +1012,11 @@
|
|
* Done with the file...
|
|
*/
|
|
|
|
+#if PNG_LIBPNG_VER > 99
|
|
+ png_destroy_read_struct (&pp, &info, NULL);
|
|
+#else
|
|
png_read_destroy (pp, info, NULL);
|
|
+#endif
|
|
|
|
g_free (pixel);
|
|
g_free (pixels);
|
|
@@ -1441,7 +1445,12 @@
|
|
};
|
|
|
|
png_write_end (pp, info);
|
|
+
|
|
+#if PNG_LIBPNG_VER > 99
|
|
+ png_destroy_write_struct (&pp, &info);
|
|
+#else
|
|
png_write_destroy (pp);
|
|
+#endif
|
|
|
|
g_free (pixel);
|
|
g_free (pixels);
|