mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
1e3f27f689
This reverts commit aa015b7770
.
59 lines
2.3 KiB
Diff
59 lines
2.3 KiB
Diff
From a599b1c2037ac8aca6c92350c8a7b3e42c81deaa Mon Sep 17 00:00:00 2001
|
|
From: Martin Peres <martin.peres@linux.intel.com>
|
|
Date: Thu, 6 Oct 2016 17:10:35 +0300
|
|
Subject: [PATCH 2/2] loader/dri3: import prime buffers in the currently-bound
|
|
screen
|
|
|
|
This tries to mirrors the codepath taken by DRI2 in IntelSetTexBuffer2()
|
|
and fixes many applications when using DRI3:
|
|
- Totem with libva on hw-accelerated decoding
|
|
- obs-studio, using Window Capture (Xcomposite) as a Source
|
|
- gstreamer with VAAPI
|
|
|
|
v2:
|
|
- introduce get_dri_screen() in the dri3 loader's vtable (krh)
|
|
|
|
Tested-by: Timo Aaltonen <tjaalton@ubuntu.com>
|
|
Tested-by: Ionut Biru <biru.ionut@gmail.com>
|
|
Cc: mesa-stable@lists.freedesktop.org
|
|
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=71759
|
|
Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
|
|
Signed-off-by: Martin Peres <martin.peres@linux.intel.com>
|
|
---
|
|
src/loader/loader_dri3_helper.c | 12 +++++++++++-
|
|
1 file changed, 11 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/src/loader/loader_dri3_helper.c b/src/loader/loader_dri3_helper.c
|
|
index 3ce0352..8179297 100644
|
|
--- a/src/loader/loader_dri3_helper.c
|
|
+++ b/src/loader/loader_dri3_helper.c
|
|
@@ -1117,6 +1117,7 @@ dri3_get_pixmap_buffer(__DRIdrawable *driDrawable, unsigned int format,
|
|
xcb_sync_fence_t sync_fence;
|
|
struct xshmfence *shm_fence;
|
|
int fence_fd;
|
|
+ __DRIscreen *cur_screen;
|
|
|
|
if (buffer)
|
|
return buffer;
|
|
@@ -1147,8 +1148,17 @@ dri3_get_pixmap_buffer(__DRIdrawable *driDrawable, unsigned int format,
|
|
if (!bp_reply)
|
|
goto no_image;
|
|
|
|
+ /* Get the currently-bound screen or revert to using the drawable's screen if
|
|
+ * no contexts are currently bound. The latter case is at least necessary for
|
|
+ * obs-studio, when using Window Capture (Xcomposite) as a Source.
|
|
+ */
|
|
+ cur_screen = draw->vtable->get_dri_screen(draw);
|
|
+ if (!cur_screen) {
|
|
+ cur_screen = draw->dri_screen;
|
|
+ }
|
|
+
|
|
buffer->image = loader_dri3_create_image(draw->conn, bp_reply, format,
|
|
- draw->dri_screen, draw->ext->image,
|
|
+ cur_screen, draw->ext->image,
|
|
buffer);
|
|
if (!buffer->image)
|
|
goto no_image;
|
|
--
|
|
2.10.0
|
|
|