mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
21 lines
761 B
Diff
21 lines
761 B
Diff
diff --git i/Makefile w/Makefile
|
|
index 7bc3788..3af1cce 100644
|
|
--- i/Makefile
|
|
+++ w/Makefile
|
|
@@ -16,10 +16,14 @@ linux:
|
|
$(CC) -shared -o libzest.so `find mruby/build/host -type f | grep -v mrbc | grep -e "\.o$$" | grep -v bin` ./deps/libnanovg.a \
|
|
./deps/libnanovg.a \
|
|
src/osc-bridge/libosc-bridge.a \
|
|
- `pkg-config --libs libuv` -lm -lX11 -lGL -lpthread
|
|
+ $(CFLAGS) \
|
|
+ `pkg-config --libs libuv` -lm -lX11 -lGL -lpthread \
|
|
+ $(LDFLAGS)
|
|
$(CC) test-libversion.c deps/pugl/pugl/pugl_x11.c \
|
|
+ $(CFLAGS) \
|
|
-DPUGL_HAVE_GL \
|
|
- -ldl -o zest -lX11 -lGL -lpthread -I deps/pugl -std=gnu99 -Wno-trigraphs
|
|
+ -ldl -o zest -lX11 -lGL -lpthread -I deps/pugl -std=gnu99 -Wno-trigraphs \
|
|
+ $(LDFLAGS)
|
|
|
|
osx: deps/libuv.a
|
|
ruby ./rebuild-fcache.rb
|