mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
63 lines
1.7 KiB
Diff
63 lines
1.7 KiB
Diff
From fed899ac086a1ee511197d3cb7da28b925c53a65 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?J=C3=A1n=20Tomko?= <jtomko@redhat.com>
|
|
Date: Mon, 13 Aug 2018 13:38:38 +0200
|
|
Subject: [PATCH 03/16] Revert "remote: daemon: Make sure that JSON symbols are
|
|
properly loaded at startup"
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
This reverts commit 3251fc9c9b9639c3fec3181530599415523d671a.
|
|
|
|
Jansson cannot parse QEMU's quirky JSON.
|
|
Revert back to yajl.
|
|
|
|
https://bugzilla.redhat.com/show_bug.cgi?id=1614569
|
|
|
|
Signed-off-by: Ján Tomko <jtomko@redhat.com>
|
|
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
|
|
---
|
|
src/libvirt_private.syms | 4 ----
|
|
src/remote/remote_daemon.c | 4 ----
|
|
2 files changed, 8 deletions(-)
|
|
|
|
diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms
|
|
index 70dfcc5e29..fc386e1699 100644
|
|
--- a/src/libvirt_private.syms
|
|
+++ b/src/libvirt_private.syms
|
|
@@ -2135,10 +2135,6 @@ virJSONValueObjectStealObject;
|
|
virJSONValueToString;
|
|
|
|
|
|
-# util/virjsoncompat.h
|
|
-virJSONInitialize;
|
|
-
|
|
-
|
|
# util/virkeycode.h
|
|
virKeycodeSetTypeFromString;
|
|
virKeycodeSetTypeToString;
|
|
diff --git a/src/remote/remote_daemon.c b/src/remote/remote_daemon.c
|
|
index 8bbc3818bb..9f3a5f38ad 100644
|
|
--- a/src/remote/remote_daemon.c
|
|
+++ b/src/remote/remote_daemon.c
|
|
@@ -59,7 +59,6 @@
|
|
#include "virutil.h"
|
|
#include "virgettext.h"
|
|
#include "util/virnetdevopenvswitch.h"
|
|
-#include "virjsoncompat.h"
|
|
|
|
#include "driver.h"
|
|
|
|
@@ -1184,9 +1183,6 @@ int main(int argc, char **argv) {
|
|
exit(EXIT_FAILURE);
|
|
}
|
|
|
|
- if (virJSONInitialize() < 0)
|
|
- exit(EXIT_FAILURE);
|
|
-
|
|
daemonSetupNetDevOpenvswitch(config);
|
|
|
|
if (daemonSetupAccessManager(config) < 0) {
|
|
--
|
|
2.18.0
|
|
|