PKGBUILDs/core/linux-am33x/musb_start_urb-oopse.patch
Kane Mathers fd9654dba5 Apply upsteam patch for musb usb host oopse
Upsteam patch information:

    3067779b15
2012-11-01 09:38:04 +08:00

14 lines
490 B
Diff

diff --git a/drivers/usb/musb/musb_host.c b/drivers/usb/musb/musb_host.c
index 4bb717d..1ae378d 100644
--- a/drivers/usb/musb/musb_host.c
+++ b/drivers/usb/musb/musb_host.c
@@ -2049,7 +2049,7 @@ static int musb_urb_enqueue(
* we only have work to do in the former case.
*/
spin_lock_irqsave(&musb->lock, flags);
- if (hep->hcpriv) {
+ if (hep->hcpriv || !next_urb(qh)) {
/* some concurrent activity submitted another urb to hep...
* odd, rare, error prone, but legal.
*/