mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
112622666f
New package is required for HW decoding with vlc-rpi. Use -mcpu in C/XXFLAGS which will limit use of this package to RPi3 and above which isn't a big loss since HW decoding on RPi2 is pretty limited. Commit also makes this a split package with the new ffmpeg-rpi-bin providing the man pages and executables stripped out in the main package to allow a full package of ffmpeg with HW decoding should someone what that.
13 lines
1.1 KiB
Diff
13 lines
1.1 KiB
Diff
diff --git a/libavfilter/vf_libvmaf.c b/libavfilter/vf_libvmaf.c
|
|
index 249e50c720..9b791e19b1 100644
|
|
--- a/libavfilter/vf_libvmaf.c
|
|
+++ b/libavfilter/vf_libvmaf.c
|
|
@@ -72,7 +72,7 @@ typedef struct LIBVMAFContext {
|
|
#define FLAGS AV_OPT_FLAG_FILTERING_PARAM|AV_OPT_FLAG_VIDEO_PARAM
|
|
|
|
static const AVOption libvmaf_options[] = {
|
|
- {"model_path", "Set the model to be used for computing vmaf.", OFFSET(model_path), AV_OPT_TYPE_STRING, {.str="/usr/local/share/model/vmaf_v0.6.1.pkl"}, 0, 1, FLAGS},
|
|
+ {"model_path", "Set the model to be used for computing vmaf.", OFFSET(model_path), AV_OPT_TYPE_STRING, {.str="/usr/share/model/vmaf_v0.6.1.pkl"}, 0, 1, FLAGS},
|
|
{"log_path", "Set the file path to be used to store logs.", OFFSET(log_path), AV_OPT_TYPE_STRING, {.str=NULL}, 0, 1, FLAGS},
|
|
{"log_fmt", "Set the format of the log (xml or json).", OFFSET(log_fmt), AV_OPT_TYPE_STRING, {.str=NULL}, 0, 1, FLAGS},
|
|
{"enable_transform", "Enables transform for computing vmaf.", OFFSET(enable_transform), AV_OPT_TYPE_BOOL, {.i64=0}, 0, 1, FLAGS},
|