mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
81 lines
3.3 KiB
Diff
81 lines
3.3 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Nirbheek Chauhan <nirbheek@centricular.com>
|
|
Date: Wed, 21 Sep 2022 19:19:45 +0530
|
|
Subject: [PATCH] meson: Use implicit builtin dirs in pkgconfig generation
|
|
|
|
Starting with Meson 0.62, meson automatically populates the variables
|
|
list in the pkgconfig file if you reference builtin directories in the
|
|
pkgconfig file (whether via a custom pkgconfig variable or elsewhere).
|
|
We need this, because ${prefix}/libexec is a hard-coded value which is
|
|
incorrect on, for example, Debian.
|
|
|
|
Bump requirement to 0.62, and remove version compares that retained
|
|
support for older Meson versions.
|
|
|
|
Fixes https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1245
|
|
|
|
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/3061>
|
|
(cherry picked from commit a0e6278dba899f122d806994d47ee0e2c1741b34)
|
|
|
|
Removed meson requirement bump to ease backporting, although this is not
|
|
strictly correct.
|
|
---
|
|
subprojects/gst-plugins-base/meson.build | 16 ++++++++--------
|
|
subprojects/gstreamer/meson.build | 17 ++++++++---------
|
|
2 files changed, 16 insertions(+), 17 deletions(-)
|
|
|
|
diff --git a/subprojects/gst-plugins-base/meson.build b/subprojects/gst-plugins-base/meson.build
|
|
index 0beccf00459e..1681484bfd54 100644
|
|
--- a/subprojects/gst-plugins-base/meson.build
|
|
+++ b/subprojects/gst-plugins-base/meson.build
|
|
@@ -440,14 +440,14 @@ if get_option('default_library') == 'shared'
|
|
plugins_pkgconfig_install_dir = disabler()
|
|
endif
|
|
|
|
-pkgconfig_variables = ['exec_prefix=${prefix}',
|
|
- 'toolsdir=${exec_prefix}/bin',
|
|
- 'pluginsdir=${libdir}/gstreamer-1.0',
|
|
- 'datarootdir=${prefix}/share',
|
|
- 'datadir=${datarootdir}',
|
|
- 'girdir=${datadir}/gir-1.0',
|
|
- 'typelibdir=${libdir}/girepository-1.0',
|
|
- 'libexecdir=${prefix}/libexec']
|
|
+pkgconfig_variables = [
|
|
+ 'exec_prefix=${prefix}',
|
|
+ 'toolsdir=${exec_prefix}/bin',
|
|
+ 'pluginsdir=${libdir}/gstreamer-1.0',
|
|
+ 'girdir=${datadir}/gir-1.0',
|
|
+ 'typelibdir=${libdir}/girepository-1.0',
|
|
+ 'pluginscannerdir=${libexecdir}/gstreamer-1.0'
|
|
+]
|
|
pkgconfig_subdirs = ['gstreamer-1.0']
|
|
|
|
meson_pkg_config_file_fixup_script = find_program('scripts/meson-pkg-config-file-fixup.py')
|
|
diff --git a/subprojects/gstreamer/meson.build b/subprojects/gstreamer/meson.build
|
|
index ce860ed140e4..adc0ee728a11 100644
|
|
--- a/subprojects/gstreamer/meson.build
|
|
+++ b/subprojects/gstreamer/meson.build
|
|
@@ -579,15 +579,14 @@ if get_option('default_library') == 'shared'
|
|
# If we don't build static plugins there is no need to generate pc files
|
|
plugins_pkgconfig_install_dir = disabler()
|
|
endif
|
|
-pkgconfig_variables = ['exec_prefix=${prefix}',
|
|
- 'toolsdir=${exec_prefix}/bin',
|
|
- 'pluginsdir=${libdir}/gstreamer-1.0',
|
|
- 'datarootdir=${prefix}/share',
|
|
- 'datadir=${datarootdir}',
|
|
- 'girdir=${datadir}/gir-1.0',
|
|
- 'typelibdir=${libdir}/girepository-1.0',
|
|
- 'libexecdir=${prefix}/libexec',
|
|
- 'pluginscannerdir=${libexecdir}/gstreamer-1.0']
|
|
+pkgconfig_variables = [
|
|
+ 'exec_prefix=${prefix}',
|
|
+ 'toolsdir=${exec_prefix}/bin',
|
|
+ 'pluginsdir=${libdir}/gstreamer-1.0',
|
|
+ 'girdir=${datadir}/gir-1.0',
|
|
+ 'typelibdir=${libdir}/girepository-1.0',
|
|
+ 'pluginscannerdir=${libexecdir}/gstreamer-1.0'
|
|
+]
|
|
pkgconfig_uninstalled_variables = ['exec_prefix=${prefix}',
|
|
'gstreamerdir=${prefix}/subprojects/gstreamer',
|
|
'bashhelpersdir=${gstreamerdir}/data/bash-completion/helpers',
|