mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
96 lines
2.5 KiB
Diff
96 lines
2.5 KiB
Diff
From 0061e430c9105b63d92ce26696b1577651ab1185 Mon Sep 17 00:00:00 2001
|
|
From: Andre Przywara <andre.przywara@arm.com>
|
|
Date: Wed, 14 Mar 2018 01:57:06 +0000
|
|
Subject: [PATCH 2/3] sunxi: revert disabling of features
|
|
|
|
In January some commits were introduced to mitigate the U-Boot image
|
|
size issues we encountered on sunxi builds.
|
|
Now with the MMC environment removed we can bring them back, as we
|
|
practically don't have a size limit anymore.
|
|
|
|
Signed-off-by: Andre Przywara <andre.przywara@arm.com>
|
|
Acked-by: Maxime Ripard <maxime.ripard@bootlin.com>
|
|
---
|
|
cmd/Kconfig | 5 -----
|
|
drivers/video/Kconfig | 2 --
|
|
lib/Kconfig | 1 -
|
|
3 files changed, 8 deletions(-)
|
|
|
|
diff --git a/cmd/Kconfig b/cmd/Kconfig
|
|
index 136836d146..27086df09b 100644
|
|
--- a/cmd/Kconfig
|
|
+++ b/cmd/Kconfig
|
|
@@ -426,7 +426,6 @@ menu "Memory commands"
|
|
config CMD_CRC32
|
|
bool "crc32"
|
|
select HASH
|
|
- default n if ARCH_SUNXI
|
|
default y
|
|
help
|
|
Compute CRC32.
|
|
@@ -568,7 +567,6 @@ config CMD_LZMADEC
|
|
|
|
config CMD_UNZIP
|
|
bool "unzip"
|
|
- default n if ARCH_SUNXI
|
|
default y if CMD_BOOTI
|
|
help
|
|
Uncompress a zip-compressed memory region.
|
|
@@ -780,14 +778,12 @@ config CMD_I2C
|
|
|
|
config CMD_LOADB
|
|
bool "loadb"
|
|
- default n if ARCH_SUNXI
|
|
default y
|
|
help
|
|
Load a binary file over serial line.
|
|
|
|
config CMD_LOADS
|
|
bool "loads"
|
|
- default n if ARCH_SUNXI
|
|
default y
|
|
help
|
|
Load an S-Record file over serial line
|
|
@@ -1187,7 +1183,6 @@ config CMD_GETTIME
|
|
# TODO: rename to CMD_SLEEP
|
|
config CMD_MISC
|
|
bool "sleep"
|
|
- default n if ARCH_SUNXI
|
|
default y
|
|
help
|
|
Delay execution for some time
|
|
diff --git a/drivers/video/Kconfig b/drivers/video/Kconfig
|
|
index 2fc0defcd0..45a105db06 100644
|
|
--- a/drivers/video/Kconfig
|
|
+++ b/drivers/video/Kconfig
|
|
@@ -38,7 +38,6 @@ config BACKLIGHT_GPIO
|
|
config VIDEO_BPP8
|
|
bool "Support 8-bit-per-pixel displays"
|
|
depends on DM_VIDEO
|
|
- default n if ARCH_SUNXI
|
|
default y if DM_VIDEO
|
|
help
|
|
Support drawing text and bitmaps onto a 8-bit-per-pixel display.
|
|
@@ -49,7 +48,6 @@ config VIDEO_BPP8
|
|
config VIDEO_BPP16
|
|
bool "Support 16-bit-per-pixel displays"
|
|
depends on DM_VIDEO
|
|
- default n if ARCH_SUNXI
|
|
default y if DM_VIDEO
|
|
help
|
|
Support drawing text and bitmaps onto a 16-bit-per-pixel display.
|
|
diff --git a/lib/Kconfig b/lib/Kconfig
|
|
index 4fd41c4282..ab581f172f 100644
|
|
--- a/lib/Kconfig
|
|
+++ b/lib/Kconfig
|
|
@@ -66,7 +66,6 @@ config PANIC_HANG
|
|
|
|
config REGEX
|
|
bool "Enable regular expression support"
|
|
- default n if ARCH_SUNXI
|
|
default y if NET
|
|
help
|
|
If this variable is defined, U-Boot is linked against the
|
|
--
|
|
2.16.3
|
|
|