mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
21 lines
1,012 B
Diff
21 lines
1,012 B
Diff
diff -r -u icedtea6-1.5.orig/patches/icedtea-libraries.patch icedtea6-1.5/patches/icedtea-libraries.patch
|
|
--- icedtea6-1.5.orig/patches/icedtea-libraries.patch 2009-05-19 14:09:16.000000000 +0200
|
|
+++ icedtea6-1.5/patches/icedtea-libraries.patch 2009-07-19 13:19:01.000000000 +0200
|
|
@@ -25052,7 +25052,7 @@
|
|
+METHODDEF(void)
|
|
+initIDs()
|
|
+{
|
|
-+ void *handle = dlopen("libjpeg.so.62", RTLD_LAZY | RTLD_GLOBAL);
|
|
++ void *handle = dlopen("libjpeg.so.7", RTLD_LAZY | RTLD_GLOBAL);
|
|
+
|
|
+ jpegstderror = (fn_jpegstderror)dlsym(handle, "jpeg_std_error");
|
|
+ if (jpegstderror == NULL) {
|
|
@@ -25343,7 +25343,7 @@
|
|
Java_sun_awt_image_JPEGImageDecoder_initIDs(JNIEnv *env, jclass cls,
|
|
jclass InputStreamClass)
|
|
{
|
|
-+ void *handle = dlopen("libjpeg.so.62", RTLD_LAZY | RTLD_GLOBAL);
|
|
++ void *handle = dlopen("libjpeg.so.7", RTLD_LAZY | RTLD_GLOBAL);
|
|
+
|
|
+ jpegstderror = (fn_jpegstderror)dlsym(handle, "jpeg_std_error");
|
|
+ if (jpegstderror == NULL) {
|