mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
36 lines
1.4 KiB
Diff
36 lines
1.4 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Michael Catanzaro <mcatanzaro@redhat.com>
|
|
Date: Fri, 31 Mar 2023 12:24:09 -0700
|
|
Subject: [PATCH] Fix build of SourceBrush.cpp
|
|
https://bugs.webkit.org/show_bug.cgi?id=254821
|
|
|
|
Unreviewed build fix.
|
|
|
|
* Source/WebCore/platform/graphics/SourceBrush.cpp:
|
|
(WebCore::SourceBrush::setGradient):
|
|
(WebCore::SourceBrush::setPattern):
|
|
|
|
Canonical link: https://commits.webkit.org/262434@main
|
|
---
|
|
Source/WebCore/platform/graphics/SourceBrush.cpp | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Source/WebCore/platform/graphics/SourceBrush.cpp b/Source/WebCore/platform/graphics/SourceBrush.cpp
|
|
index f4d299be82f1..4bf4d6842aea 100644
|
|
--- a/Source/WebCore/platform/graphics/SourceBrush.cpp
|
|
+++ b/Source/WebCore/platform/graphics/SourceBrush.cpp
|
|
@@ -65,12 +65,12 @@ Pattern* SourceBrush::pattern() const
|
|
|
|
void SourceBrush::setGradient(Ref<Gradient>&& gradient, const AffineTransform& spaceTransform)
|
|
{
|
|
- m_brush = { Brush::LogicalGradient { WTFMove(gradient), spaceTransform } };
|
|
+ m_brush = Brush { Brush::LogicalGradient { WTFMove(gradient), spaceTransform } };
|
|
}
|
|
|
|
void SourceBrush::setPattern(Ref<Pattern>&& pattern)
|
|
{
|
|
- m_brush = { Brush::Variant { std::in_place_type<Ref<Pattern>>, WTFMove(pattern) } };
|
|
+ m_brush = Brush { Brush::Variant { std::in_place_type<Ref<Pattern>>, WTFMove(pattern) } };
|
|
}
|
|
|
|
WTF::TextStream& operator<<(TextStream& ts, const SourceBrush& brush)
|