PKGBUILDs/core/pacman/0002-Revert-close-stdin-before-running-install-scripts.patch
2019-05-21 01:01:58 +00:00

33 lines
1 KiB
Diff

From c0836b1f802f54c793618823f5d1bb649a13e85d Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 30 Jan 2016 17:19:03 -0700
Subject: [PATCH 2/4] Revert "close stdin before running install scripts"
This reverts commit e374e6829cea3512f0b4a4069c5a6168f0f8d8a0.
Arch Linux ARM packages have use cases for this feature, such as
prompting the user to flash a new kernel to a bare partition. Removing
this feature will undoubtedly cause more problems than it intends to
solve.
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
lib/libalpm/util.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
index d33eef2a..e08cb923 100644
--- a/lib/libalpm/util.c
+++ b/lib/libalpm/util.c
@@ -627,7 +627,6 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
if(pid == 0) {
/* this code runs for the child only (the actual chroot/exec) */
- close(0);
close(1);
close(2);
while(dup2(child2parent_pipefd[HEAD], 1) == -1 && errno == EINTR);
--
2.21.0