mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
14 lines
439 B
Diff
14 lines
439 B
Diff
diff --git a/elf/dl-object.c b/elf/dl-object.c
|
|
index 22a1635..7674d49 100644
|
|
--- a/elf/dl-object.c
|
|
+++ b/elf/dl-object.c
|
|
@@ -214,6 +214,9 @@ _dl_new_object (char *realname, const char *libname, int type,
|
|
out:
|
|
new->l_origin = origin;
|
|
}
|
|
+ else if (INTUSE(__libc_enable_secure) && type == lt_executable)
|
|
+ /* The origin of a privileged program cannot be trusted. */
|
|
+ new->l_origin = (char *) -1;
|
|
|
|
return new;
|
|
}
|