PKGBUILDs/extra/firefox/no-relinking.patch
2019-10-03 23:08:05 +00:00

42 lines
1 KiB
Diff

# HG changeset patch
# User Mike Shal <mshal@mozilla.com>
# Date 1570127498 25200
# Node ID b8bc2504f108d8a2216ee11405cbbe4cf7a0eaec
# Parent 9a4d6aacc48080f019024c02ac7da1fd576b39fe
Bug XYZ - Only force re-linking on 1-tier PGO builds; r?#firefox-build-system-reviewers
diff --git a/config/rules.mk b/config/rules.mk
--- a/config/rules.mk
+++ b/config/rules.mk
@@ -465,25 +465,27 @@ ifeq ($(OS_ARCH)_$(GNU_CC), WINNT_)
$(foreach pgd,$(wildcard *.pgd),pgomgr -clear $(pgd);)
else
ifdef GNU_CC
-$(RM) *.gcda
endif
endif
endif
+ifdef MOZ_1TIER_PGO
ifneq (,$(MOZ_PROFILE_GENERATE)$(MOZ_PROFILE_USE))
ifneq (,$(filter target,$(MAKECMDGOALS)))
ifdef GNU_CC
# Force rebuilding libraries and programs in both passes because each
# pass uses different object files.
$(PROGRAM) $(SHARED_LIBRARY) $(LIBRARY): FORCE
endif
endif
endif
+endif
endif # NO_PROFILE_GUIDED_OPTIMIZE
##############################################
clean clobber realclean clobber_all::
-$(RM) $(ALL_TRASH)
-$(RM) -r $(ALL_TRASH_DIRS)